[Yardım]  Tek formülde eğer ve yatayara kullanımı

Excel sayfalarında kullandığımız yerleşik fonksiyonlar ya da kendi yazabileceğiniz fonksiyonlar ile ilgili bilmek istedikleriniz, sorunlar ve çözümleri

Tek formülde eğer ve yatayara kullanımı

İleti#1)  enginerinc » 30 Arl 2017 22:44

merhaba,

ekli dosyada sayfa 1 deki dataları kullanarak ilgili tarihlerde statü rakamları sayfa 2 ye yazdırılmaya çalışılıyor.
İST Taksim Ş şubesine kadar ( Taksim dahil ) rakamlar doğru gelirken sonrasında yanlış sonuç döndürüyor.

örneğin ;

İST Taksim Ş Filo 496 ve doğru olarak geliyor. sonrasında T1 üzerinden şube değiştiğinde İST YENIKAPI 0 gelmesi gerekirken 82 döndürüyor.

Hatanın nedeni yada çözüme hakkında bilgisi verilmesini rica ederim.

Teşekkür ederim
Bu iletideki ekleri görmek için gerekli yetkilere sahip değilsiniz.
Kullanıcı avatarı
enginerinc
 
Kayıt: 30 Arl 2017 22:23
Meslek: DOKTOR
Yaş: 40
İleti: 1
 
Cinsiyet: Bay
Bulunduğunuz İl / Semt: istanbul

Cevap: Tek formülde eğer ve yatayara kullanımı

İleti#2)  şahin » 01 Oca 2018 01:35

ekte

SOR.rar
Bu iletideki ekleri görmek için gerekli yetkilere sahip değilsiniz.
Kullanıcı avatarı
şahin
Siteye Alışmış
 
Kayıt: 30 Eyl 2016 23:24
Meslek: memur
Yaş: 29
İleti: 285
 
Cinsiyet: Bay
Bulunduğunuz İl / Semt: bursa

Cevap: Tek formülde eğer ve yatayara kullanımı

İleti#3)  şahin » 01 Oca 2018 17:13

Yatayara formülünü tam eşleşme modunda (YANLIŞ=tam eşleşme, DOĞRU=yaklaşık eşleşme) yaparsanız kesin sonuç elde edilir.

=+EĞER(D3<BUGÜN();YATAYARA($T$1;Sayfa1!$LY$2:$MZ$33;C3+1;YANLIŞ);J2)
Kullanıcı avatarı
şahin
Siteye Alışmış
 
Kayıt: 30 Eyl 2016 23:24
Meslek: memur
Yaş: 29
İleti: 285
 
Cinsiyet: Bay
Bulunduğunuz İl / Semt: bursa


Forum Kullanıcı Tanımlı Fonksiyonlar ( KTF )

Online Kullanıcılar

Bu forumu görüntüleyenler: Kayıtlı kullanıcı yok ve 1 misafir

Bumerang - Yazarkafe