Aynı anda Düşey ve Yatay arama

Excel sayfalarında kullandığımız yerleşik fonksiyonlar ya da kendi yazabileceğiniz fonksiyonlar ile ilgili bilmek istedikleriniz, sorunlar ve çözümleri

Aynı anda Düşey ve Yatay arama

İleti#1)  wolky78 » 09 Şub 2019 14:02

Merhaba,
Ekteki tablamda A15 ve B15 hücreleri değiştiğinde tablomda düşey ve yatay arama yaparak yüzdeli değeri nasıl getirebilirim. Teşekkürler tablom ektedir.
Bu iletideki ekleri görmek için gerekli yetkilere sahip değilsiniz.
Kullanıcı avatarı
wolky78
Siteye Alışmış
 
Adı Soyadı:volkan delebeler
Kayıt: 12 Ekm 2012 10:28
İleti: 298
 
Cinsiyet: Bay
Bulunduğunuz İl / Semt: istanbul

Cevap: Aynı anda Düşey ve Yatay arama

İleti#2)  tasad » 09 Şub 2019 15:23

Sayfa koduna kaydedin.
Kod: Tümünü seç
Option Compare Text
Private Sub Worksheet_Change(ByVal Target As Range)
Dim sat As Long, sut As Long
On Error Resume Next
If Intersect(Target, [a15:b15]) Is Nothing Then Exit Sub
For sat = 3 To Range("a12").End(3).Row
  For sut = 2 To Cells(3, Columns.Count).End(xlToLeft).Column
   If Cells(sat, 1).Value = [a15].Value And Cells(2, sut).Value = [b15].Value Then
     [c15] = Cells(sat, sut).Offset(0, 1).Text
   End If
  Next
Next
End Sub
Kullanıcı avatarı
tasad
Siteye Alışmış
 
Kayıt: 04 Şub 2018 11:46
Meslek: muhasebeci
Yaş: 27
İleti: 438
 
Cinsiyet: Bay
Bulunduğunuz İl / Semt: ısparta

Cevap: Aynı anda Düşey ve Yatay arama

İleti#3)  hasan14 » 09 Şub 2019 15:51

C15 Hücresine kopyalayınız.Biçimi % ayarlayınız.
Kod: Tümünü seç
=EĞERHATA(İNDİS($B$3:$Y$10;KAÇINCI($A$15;$A$3:$A$10;0);KAÇINCI($B$15;$B$2:$Y$2;0)+1);"")
Kullanıcı avatarı
hasan14
Siteye Alışmış
 
Kayıt: 28 Ağu 2016 17:26
Meslek: eğitim
Yaş: 57
İleti: 378
 
Cinsiyet: Bay
Bulunduğunuz İl / Semt: zonguldak

Cevap: Aynı anda Düşey ve Yatay arama

İleti#4)  wolky78 » 09 Şub 2019 16:32

iki cevap içinde teşekkürler
Kullanıcı avatarı
wolky78
Siteye Alışmış
 
Adı Soyadı:volkan delebeler
Kayıt: 12 Ekm 2012 10:28
İleti: 298
 
Cinsiyet: Bay
Bulunduğunuz İl / Semt: istanbul

REKLAM
Excel Logo XML Oluşturucu
Logo Object Designer ile Uyarlama

Forum Kullanıcı Tanımlı Fonksiyonlar ( KTF )

Online Kullanıcılar

Bu forumu görüntüleyenler: Kayıtlı kullanıcı yok ve 1 misafir

Bumerang - Yazarkafe