[Yardım]  Sanırım makroyla mümkün ?

Excel hakkındaki soru ya da paylaşımlarınıza kategori bulamadıysanız bu alana yazabilirsiniz.

Sanırım makroyla mümkün ?

İleti#1)  tanerozcan » 13 Haz 2018 22:28

Selam arkadaşlar,

A sütununda 20 gördüğü her satırın D sütununa Ahmet yazsın


Böyle bişey mümkün mü?
Kullanıcı avatarı
tanerozcan
Yeni Başlamış
 
Kayıt: 23 May 2016 15:07
Meslek: Muhasebe
Yaş: 42
İleti: 13
 
Cinsiyet: Bay
Bulunduğunuz İl / Semt: İstanbul

Cevap: Sanırım makroyla mümkün ?

İleti#2)  muhammedyuksel » 13 Haz 2018 23:19

Merhaba Taner bey, bu kod ile yapabilirsiniz.
Kod: Tümünü seç
Private Sub ahmet()
For b = 1 To Range("A1048576").End(xlUp).Row
    If Range("a" & b).Value = 20 Then
    Range("d" & b).Value = "Ahmet"
    End If
Next
End Sub
Kullanıcı avatarı
muhammedyuksel
 
Kayıt: 04 Haz 2018 22:02
Meslek: Memur
Yaş: 26
İleti: 5
 
Cinsiyet: Bay
Bulunduğunuz İl / Semt: Yozgat

Cevap: Sanırım makroyla mümkün ?

İleti#3)  hasan14 » 14 Haz 2018 01:05

Syfa kodu olarak kopyalyınız.
Kod: Tümünü seç
Private Sub Worksheet_Change(ByVal Target As Range)
If Intersect(Target, [A:A]) Is Nothing Then Exit Sub
On Error Resume Next
If Target.Value = 20 Then
Target.Offset(0, 3) = "Ahmet"
End If
If Target.Value <> 20 Then
Target.Offset(0, 3) = ""
End If
End Sub

veya formül olarak D1 hücresine kopyalayınız.Aşağı çekerel çoğaltınız.
Kod: Tümünü seç
=EĞER($A1=20;"Ahmet";"")
Kullanıcı avatarı
hasan14
Siteye Alışmış
 
Kayıt: 28 Ağu 2016 17:26
Meslek: eğitim
Yaş: 57
İleti: 350
 
Cinsiyet: Bay
Bulunduğunuz İl / Semt: zonguldak

Cevap: Sanırım makroyla mümkün ?

İleti#4)  tanerozcan » 26 Haz 2018 22:20

Arkadaşlar hepinize teşekkürler şkşk
Kullanıcı avatarı
tanerozcan
Yeni Başlamış
 
Kayıt: 23 May 2016 15:07
Meslek: Muhasebe
Yaş: 42
İleti: 13
 
Cinsiyet: Bay
Bulunduğunuz İl / Semt: İstanbul

REKLAM
Excel Logo XML Oluşturucu
Logo Object Designer ile Uyarlama

Forum Diğer Excel İşlemleri

Online Kullanıcılar

Bu forumu görüntüleyenler: Google [Bot], Google Adsense [Bot], kaos9611 ve 2 misafir

Bumerang - Yazarkafe