Düşeyara ile doluysa boşsa

Excel hakkındaki soru ya da paylaşımlarınıza kategori bulamadıysanız bu alana yazabilirsiniz.

Düşeyara ile doluysa boşsa

İleti#1)  teyadih » 27 Haz 2018 15:05

Kolay gelsin arkadaşlar. Bir kişiye ait farklı bir yerdeki bilgiyi almak için =EĞERHATA(DÜŞEYARA(E5;E17:K929;7;0);0) düşey ara formülünü kullanıyorum. Bu formülü eğer doluysa 7.satırdakini boşsa 24.satırdakini alsın şeklinde düzeltebilir miyiz?
Kullanıcı avatarı
teyadih
Siteye Alışmış
 
Kayıt: 12 Şub 2017 18:07
Meslek: Memur
Yaş: 43
İleti: 159
 
Cinsiyet: Bay
Bulunduğunuz İl / Semt: İstanbul/Yenibosna

Cevap: Düşeyara ile doluysa boşsa

İleti#2)  teyadih » 27 Haz 2018 16:58

Eksik bilgi oldu satır değil sütun olacaktı. eğer doluysa 7.sütundakini boşsa 24.sütundakini alsın şeklinde düzeltebilir miyiz?
Kullanıcı avatarı
teyadih
Siteye Alışmış
 
Kayıt: 12 Şub 2017 18:07
Meslek: Memur
Yaş: 43
İleti: 159
 
Cinsiyet: Bay
Bulunduğunuz İl / Semt: İstanbul/Yenibosna

Cevap: Düşeyara ile doluysa boşsa

İleti#3)  MDAGISTANLI » 27 Haz 2018 19:12

Kod: Tümünü seç
=EĞER(DÜŞEYARA(E5;$E$17:$AB$929;7;0)="";DÜŞEYARA(E5;$E$17:$AB$929;24;0);DÜŞEYARA(E5;$E$17:$AB$929;7;0))
Kullanıcı avatarı
MDAGISTANLI
Yeni Başlamış
 
Kayıt: 28 Arl 2017 18:57
Meslek: Microsoft Sistem Yöneticisi
Yaş: 39
İleti: 63
 
Cinsiyet: Bay
Bulunduğunuz İl / Semt: İstanbul / Başakşehir

Cevap: Düşeyara ile doluysa boşsa

İleti#4)  hamidgf » 27 Haz 2018 19:24

#1 Eğer
http://lmgtfy.com/?q=excel+e%C4%9Fer
ilk sonuçtan
> EĞER(Bir şey Doğru ise, o zaman bir şey yap, değilse başka bir şey yap)
> EĞER(mantıksal_sınama, eğer_doğruysa_değer, [eğer_yanlışsa_değer])

#2 mantıksal_sınama
Bu formülü eğer doluysa

http://lmgtfy.com/?q=excel+h%C3%BCcre+doluysa
>ilk sonuçtan ="" sorgusu
DÜŞEYARA(E5;E17:K929;7;0) boş mu? = =DÜŞEYARA(E5;E17:K929;7;0)=""
Eğer boşsa DOĞRU, doluysa YANLIŞ değerini verecektir

#3 eğer_doğruysa_değer
#2 de görüldüğü üzere boşsa DOĞRU ya yönlendirmektedir.
boşsa 24.sütundakini alsın şeklinde

=DÜŞEYARA(E5;E17:K929;24;0) (sadece 7 değerini 24 yaptım, tablo dizini 24 lük değil orası ayrı konu.)

#4 eğer_yanlışsa_değer
#2 de görüldüğü üzere doluysa YANLIŞ a yönlendirmektedir.
eğer doluysa 7.sütundakine

=DÜŞEYARA(E5;E17:K929;7;0)

Basit bir arama ile çokta zor görünmemekte...

Forumda arama yapmak için search.php adresini veya sağ üst köşeden gelişmiş aramayı, genelde arama yapmak için google kullanmanızı önerir iyi çalışmalar dilerim.
Kullanıcı avatarı
hamidgf
Yeni Başlamış
 
Kayıt: 01 Mar 2018 15:02
Meslek: Harita Mühendisi
Yaş: 26
İleti: 36
 
Cinsiyet: Bay
Bulunduğunuz İl / Semt: Kırşehir

REKLAM
Excel Logo XML Oluşturucu
Logo Object Designer ile Uyarlama

Cevap: Düşeyara ile doluysa boşsa

İleti#5)  teyadih » 28 Haz 2018 09:46

Teşekkür ederim sayın MDAGISTANLI ve sayın hamidgf elinize sağlık.
Kullanıcı avatarı
teyadih
Siteye Alışmış
 
Kayıt: 12 Şub 2017 18:07
Meslek: Memur
Yaş: 43
İleti: 159
 
Cinsiyet: Bay
Bulunduğunuz İl / Semt: İstanbul/Yenibosna

Cevap: Düşeyara ile doluysa boşsa

İleti#6)  teyadih » 28 Haz 2018 10:47

Sayın formül boş olduğunda #YOK hatası veriyor. =EĞERHATA(DÜŞEYARA(E5;$E$17:$AB$929;7;0)="";DÜŞEYARA(E5;$E$17:$AB$929;24;0);DÜŞEYARA(E5;$E$17:$AB$929;7;0)) şeklinde düzelttim bu seferde bu işlem için çok fazla bağımsız değişken girdiniz uyarısı veriyor. Formülün sonuna ) ekledim ama yine olmadı. Sıkıntı nedir acaba
Kullanıcı avatarı
teyadih
Siteye Alışmış
 
Kayıt: 12 Şub 2017 18:07
Meslek: Memur
Yaş: 43
İleti: 159
 
Cinsiyet: Bay
Bulunduğunuz İl / Semt: İstanbul/Yenibosna

REKLAM
ETA - Excel Konsolide Raporlama
ETA Excel Personel Entegre Raporu

Cevap: Düşeyara ile doluysa boşsa

İleti#7)  metehan8001 » 28 Haz 2018 11:18

Kod: Tümünü seç
=EĞERHATA(EĞER(DÜŞEYARA(E5;$E$17:$AB$929;7;0)="";DÜŞEYARA(E5;$E$17:$AB$929;24;0);DÜŞEYARA(E5;$E$17:$AB$929;7;0));0)
Kullanıcı avatarı
metehan8001
Siteye Alışmış
 
Adı Soyadı:mete han
Kayıt: 18 Ekm 2011 10:30
İleti: 359
 
Cinsiyet: Bay
Bulunduğunuz İl / Semt: OSMANİYE

Cevap: Düşeyara ile doluysa boşsa

İleti#8)  MDAGISTANLI » 28 Haz 2018 11:43

EĞERHATA'yı doğru eklemişsiniz, ifadenin sonuna ; koyduktan sonra "" yaparsanız boş geçer 0 koyarsanız 0 yazar. 0 yerine başka birşey de yazabilirsiniz.

metehan8001 doğru yazmış. 0 yerine "" ı da deneyin.
Kullanıcı avatarı
MDAGISTANLI
Yeni Başlamış
 
Kayıt: 28 Arl 2017 18:57
Meslek: Microsoft Sistem Yöneticisi
Yaş: 39
İleti: 63
 
Cinsiyet: Bay
Bulunduğunuz İl / Semt: İstanbul / Başakşehir

Cevap: Düşeyara ile doluysa boşsa

İleti#9)  teyadih » 29 Haz 2018 09:58

Teşekkür ederim Sayın metehan8001 ve Sayın MDAGISTANLI elinize sağlık
Kullanıcı avatarı
teyadih
Siteye Alışmış
 
Kayıt: 12 Şub 2017 18:07
Meslek: Memur
Yaş: 43
İleti: 159
 
Cinsiyet: Bay
Bulunduğunuz İl / Semt: İstanbul/Yenibosna


Forum Diğer Excel İşlemleri

Online Kullanıcılar

Bu forumu görüntüleyenler: Kayıtlı kullanıcı yok ve 1 misafir

Bumerang - Yazarkafe