Aynı kişiye ait olan aynı sütunlar

Excel hakkındaki soru ya da paylaşımlarınıza kategori bulamadıysanız bu alana yazabilirsiniz.

Aynı kişiye ait olan aynı sütunlar

İleti#1)  teyadih » 02 Tem 2018 11:35

Kolay gelsin arkadaşlar. Öncelikle açmış olduğum Belirli şartları taşıyorsa ve büyükse küçükse konusunda yardımcı olan sayın Ali ÖZ'e teşekkür ederken sehven Ömer diye yazmışım. Kusura bakmayın sayın Ali ÖZ her şey için teşekkür ederim. Konu kapalı olduğu için oradan yazamadım.
Soruma gelince.
Yıl içinde alınan raporların takibi için kullandığım excel listesine A sütununda bulunan sicil numaralarına göre E sütununa aynı tarih girildiğinde W sütununa ... satırda var uyarısı verecek eğerli bir formüle ihtiyacım var.
Forumda aradım ama benzer bir şey göremedim.
Detaylı açıklama eklediğim örnek dosyada var. Teşekkür ederim

https://www.dosyaupload.com/qwUV
Bu iletideki ekleri görmek için gerekli yetkilere sahip değilsiniz.
Kullanıcı avatarı
teyadih
Siteye Alışmış
 
Kayıt: 12 Şub 2017 18:07
Meslek: Memur
Yaş: 43
İleti: 159
 
Cinsiyet: Bay
Bulunduğunuz İl / Semt: İstanbul/Yenibosna

Cevap: Ayı kişiye ait olan aynı sütunler

İleti#2)  ataköylü-59 » 02 Tem 2018 15:48

Sayın teyadih
Örnek dosyanızın Rapor listesi sayfası W4 hücresine:
Kod: Tümünü seç
=EĞER(ÇOKEĞERSAY($B$4:B4;B4;$F$4:F4;F4)>1;"Satırda var";"")
Yazıp aşağıya kopyalayarak deneyin.
Kullanıcı avatarı
ataköylü-59
Siteye Alışmış
 
Adı Soyadı:Ali Rıza Günaydı
Kayıt: 05 Ağu 2014 13:34
Konum: G.Osmanpaşa-İst.
Meslek: Emekli
Yaş: 70
İleti: 196
 
Cinsiyet: Bay
Bulunduğunuz İl / Semt: İst.

Cevap: Ayı kişiye ait olan aynı sütunler

İleti#3)  teyadih » 02 Tem 2018 17:27

Sayın ataköylü-59 formül tamam ancak örnekteki gibi önceki giriş hangi satırda girilmiş ise belirtecek şekilde yani 2.satırda var şeklinde düzenleyebilir misiniz.
Kullanıcı avatarı
teyadih
Siteye Alışmış
 
Kayıt: 12 Şub 2017 18:07
Meslek: Memur
Yaş: 43
İleti: 159
 
Cinsiyet: Bay
Bulunduğunuz İl / Semt: İstanbul/Yenibosna

Cevap: Ayı kişiye ait olan aynı sütunler

İleti#4)  ataköylü-59 » 03 Tem 2018 14:56

Sayın teyadih
Sizce girilen kayıtların 2 şartlı olarak mükerrer girildiğini tesbit edip en son girilen kaydı silme amaçlı olarak çözüm istediğinizi anlamıştım. O zaman sorunuzun cevabı W2 hücresine:
Kod: Tümünü seç
=EĞER(B4<>"";EĞERHATA(EĞER(SATIR()-2-KAÇINCI(B4&F4;$B$3:B4&$F$3:F4;0)=0;"";KAÇINCI(B4&F4;$B$3:B4&$F$3:F4;0)-1& " . Satırda var");"");"")

Bunu yazıp deneyin. Formül Dizi formülüdür.
Kullanıcı avatarı
ataköylü-59
Siteye Alışmış
 
Adı Soyadı:Ali Rıza Günaydı
Kayıt: 05 Ağu 2014 13:34
Konum: G.Osmanpaşa-İst.
Meslek: Emekli
Yaş: 70
İleti: 196
 
Cinsiyet: Bay
Bulunduğunuz İl / Semt: İst.

REKLAM
Excel Logo XML Oluşturucu
Logo Object Designer ile Uyarlama

Cevap: Ayı kişiye ait olan aynı sütunler

İleti#5)  teyadih » 03 Tem 2018 16:16

Teşekkür ederim sayın Ataköylü-59
Kullanıcı avatarı
teyadih
Siteye Alışmış
 
Kayıt: 12 Şub 2017 18:07
Meslek: Memur
Yaş: 43
İleti: 159
 
Cinsiyet: Bay
Bulunduğunuz İl / Semt: İstanbul/Yenibosna

Cevap: Ayı kişiye ait olan aynı sütunler

İleti#6)  teyadih » 03 Tem 2018 16:35

Sayın ataköylü bazen izinleri erken kesip gelenler oluyor. Bunu tespit etmek için formüle G sütununu da ekleyip hepsi aynı ise ... satırda var, G farklı ise ... satırda var G sütunu farklı şeklinde düzenleme şansımız var mı?
Örnek dosyayı ekledim. En sondaki 2 girişin yanına yazdım. Teşekkür ederim
Bu iletideki ekleri görmek için gerekli yetkilere sahip değilsiniz.
Kullanıcı avatarı
teyadih
Siteye Alışmış
 
Kayıt: 12 Şub 2017 18:07
Meslek: Memur
Yaş: 43
İleti: 159
 
Cinsiyet: Bay
Bulunduğunuz İl / Semt: İstanbul/Yenibosna

REKLAM
ETA - Excel Konsolide Raporlama
ETA Excel Personel Entegre Raporu

Cevap: Ayı kişiye ait olan aynı sütunler

İleti#7)  ataköylü-59 » 03 Tem 2018 17:58

Sayın teyadih,
Dosyanız ektedir. Sanırım istediğiniz gibi olmuştur.
Bu iletideki ekleri görmek için gerekli yetkilere sahip değilsiniz.
Kullanıcı avatarı
ataköylü-59
Siteye Alışmış
 
Adı Soyadı:Ali Rıza Günaydı
Kayıt: 05 Ağu 2014 13:34
Konum: G.Osmanpaşa-İst.
Meslek: Emekli
Yaş: 70
İleti: 196
 
Cinsiyet: Bay
Bulunduğunuz İl / Semt: İst.

Cevap: Ayı kişiye ait olan aynı sütunler

İleti#8)  teyadih » 04 Tem 2018 10:36

Sayın Ataköylü W sütununda mevcut olanlar var diye ben sadece son değişikliğin uyarısın vermişti eksik olmuş sanırım. kusura bakmayın yordum sizi. Eğer hepsi aynı ise ... satırda var, G farklı ise ... satırda var G sütunu farklı şeklinde düzenleme şansımız var mı? Yani gönderdiğiniz son örnek dosyanın X sütunundaki formüle 14.satırdaki Osman gider için de 5.satırda var şeklinde uyarı verecek şekilde düzenleyebilirseniz. Örnek dosyayı gönderiyorum. Teşekkür ederim ilginize
Bu iletideki ekleri görmek için gerekli yetkilere sahip değilsiniz.
Kullanıcı avatarı
teyadih
Siteye Alışmış
 
Kayıt: 12 Şub 2017 18:07
Meslek: Memur
Yaş: 43
İleti: 159
 
Cinsiyet: Bay
Bulunduğunuz İl / Semt: İstanbul/Yenibosna

Cevap: Ayı kişiye ait olan aynı sütunler

İleti#9)  ataköylü-59 » 04 Tem 2018 13:05

Sayın teyadih,
W sütununda yeniden bir düzenleme yaptım. Ancak istediğiniz şeyi tek sütunda kurgulayamadım. Ancak bu haliyle de işinizi görür idare edersiniz. Benim elimden delen budur.
Bu iletideki ekleri görmek için gerekli yetkilere sahip değilsiniz.
Kullanıcı avatarı
ataköylü-59
Siteye Alışmış
 
Adı Soyadı:Ali Rıza Günaydı
Kayıt: 05 Ağu 2014 13:34
Konum: G.Osmanpaşa-İst.
Meslek: Emekli
Yaş: 70
İleti: 196
 
Cinsiyet: Bay
Bulunduğunuz İl / Semt: İst.

Cevap: Ayı kişiye ait olan aynı sütunler

İleti#10)  teyadih » 04 Tem 2018 15:28

Teşekkür ederim sayın Ataköylü Elinize sağlık. W ve X deki formülleri birleştirmeyle Y sütununa alayım. Hangisi gelirse oradan atar. Her şey için sağ olun kolay gelsin
Kullanıcı avatarı
teyadih
Siteye Alışmış
 
Kayıt: 12 Şub 2017 18:07
Meslek: Memur
Yaş: 43
İleti: 159
 
Cinsiyet: Bay
Bulunduğunuz İl / Semt: İstanbul/Yenibosna


Forum Diğer Excel İşlemleri

Online Kullanıcılar

Bu forumu görüntüleyenler: Kayıtlı kullanıcı yok ve 1 misafir

Bumerang - Yazarkafe