iç içe eğer formülü hatası

Excel hakkındaki soru ya da paylaşımlarınıza kategori bulamadıysanız bu alana yazabilirsiniz.

iç içe eğer formülü hatası

İleti#1)  secret_boy » 28 Kas 2019 15:17

=EĞER(AC8<18000;AF8*0.15;
EĞER(AC8>=18000;AF8*0.2;
EĞER(VE(AD8>18000;AC8<18000);(AD8-18000)*0.2+
EĞER(VE(AD8>18000;AC8<18000);AF8-(AD8-18000)*0.15));
EĞER(AD8<40000;AF8*0.20;
EĞER(AC8>=40000;AF8*0.27;
EĞER(VE(AD8>40000;AC8<40000);AD8-40000)*0.27+
EĞER(VE(AD8>40000;AC8<40000);AF8-(AD8-40000))*0.20))))))))

merhaba arkadaşlar yukarıdaki formülde
=EĞER(AC8<18000;AF8*0.15;
EĞER(AC8>=18000;AF8*0.2;
EĞER(VE(AD8>18000;AC8<18000);(AD8-18000)*0.2+
EĞER(VE(AD8>18000;AC8<18000);AF8-(AD8-18000)*0.15)) formülü çalışıyor fakat birleştirme yaptığımda devamı olan
EĞER(AD8<40000;AF8*0.20;
EĞER(AC8>=40000;AF8*0.27;
EĞER(VE(AD8>40000;AC8<40000);AD8-40000)*0.27+
EĞER(VE(AD8>40000;AC8<40000);AF8-(AD8-40000))*0.20)))))))) formül işleme alınmıyor sebebi nedir acaba
Kullanıcı avatarı
secret_boy
Yeni Başlamış
 
Adı Soyadı:hakan ulusoy
Kayıt: 21 Nis 2014 02:32
Konum: konya
Meslek: Bilgi İşlem Sorumlusu
Yaş: 35
İleti: 16
 
Cinsiyet: Bay
Bulunduğunuz İl / Semt: konya

Cevap: iç içe eğer formülü hatası

İleti#2)  AkcanAdana » 28 Kas 2019 16:04

Bu kadar fazla eğer kullanamazsın. Sanırım sınır 7 tane
Kullanıcı avatarı
AkcanAdana
Siteye Alışmış
 
Kayıt: 08 Şub 2017 22:44
Meslek: Ticaret
Yaş: 57
İleti: 156
 
Cinsiyet: Bay
Bulunduğunuz İl / Semt: Adana/Seyhan

Cevap: iç içe eğer formülü hatası

İleti#3)  secret_boy » 29 Kas 2019 07:44

peki bunu nasıl kısaltabiliriz?
Kullanıcı avatarı
secret_boy
Yeni Başlamış
 
Adı Soyadı:hakan ulusoy
Kayıt: 21 Nis 2014 02:32
Konum: konya
Meslek: Bilgi İşlem Sorumlusu
Yaş: 35
İleti: 16
 
Cinsiyet: Bay
Bulunduğunuz İl / Semt: konya

Cevap: iç içe eğer formülü hatası

İleti#4)  hasan14 » 29 Kas 2019 10:56

=EĞER(AC8<18000;AF8*0.15;
EĞER(AC8>=18000;AF8*0.2;
EĞER(VE(AD8>18000;AC8<18000);(AD8-18000)*0.2+
EĞER(VE(AD8>18000;AC8<18000);AF8-(AD8-18000)*0.15));
EĞER(AD8<40000;AF8*0.20;
EĞER(AC8>=40000;AF8*0.27;
EĞER(VE(AD8>40000;AC8<40000);AD8-40000)*0.27+
EĞER(VE(AD8>40000;AC8<40000);AF8-(AD8-40000))*0.20))))))))
Formülünüzde yazım hataları ve kurulma mantığında hatalar var.Aynı değerler için farklı eğerler oluşturulmuş yanlış. Eeğerle + ile birleştirilmiş bence hatalı. Önerim :Yapmak istediğinizi örnek bir dosya ekliyerek yazınız. Yeniden formül oluşturulsun.Tabii siz bilirsiniz.
Kullanıcı avatarı
hasan14
Siteye Alışmış
 
Kayıt: 28 Ağu 2016 15:26
Meslek: eğitim
Yaş: 59
İleti: 487
 
Cinsiyet: Bay
Bulunduğunuz İl / Semt: zonguldak

REKLAM
Excel Logo XML Oluşturucu
Logo Object Designer ile Uyarlama

Cevap: iç içe eğer formülü hatası

İleti#5)  Tarkan VURAL » 12 Arl 2019 14:59

Merhaba,
İç içe yönteminden kurtararak, tek bir eğer şart oluşturup yanına diğer Eğer şartlarını + ile bol miktarda ekleyebilirsiniz. Şart oluşmama durumuna etkisiz eleman olan sıfır değerini verin. Tabi kriterleriniz buna uygun ise.

Örnek :
=Eğer(A1="İstanbul";100;0) + Eğer(A1="Ankara",90,0) + Eğer(A1="İzmir",80,0)+...
Resim
www.tarkanvural.com.tr

İnnâ lillâhi ve innâ ileyhi raciûn
Şüphesiz ki; biz Allah’a âidiz ve vakti geldiğinde O’na döndürüleceğiz.

HasbunAllâhu ve nimel vekîl
Bize Allah yeter. O ne güzel vekildir.


ExcelVBA.NET' e katkıda bulunmak ister misiniz ?
Kullanıcı avatarı
Tarkan VURAL
Yönetim Kurulu
 
Adı Soyadı:Tarkan VURAL
Kayıt: 14 Haz 2008 18:27
Konum: @tarkanvural73
Meslek: LUU, Database Expert, Senior Software Specialist, Developer
Yaş: 46
İleti: 27342
 
Cinsiyet: Bay
Bulunduğunuz İl / Semt: İstanbul - Beylikdüzü


Forum Diğer Excel İşlemleri

Online Kullanıcılar

Bu forumu görüntüleyenler: Kayıtlı kullanıcı yok ve 0 misafir

Bumerang - Yazarkafe