[Yardım]  Hücredeki veriyi algılayıp tablodan hücre aktarma

Excel dersleri ile ilgili sormak istediklerinizi paylaşabileceğiniz alan

Hücredeki veriyi algılayıp tablodan hücre aktarma

İleti#1)  Kaan Oğuz » 20 May 2018 23:56

Tablomuzda B2 hücresinde Kaan, C2 hücresinde Oğuz yazsın
B3 hücresinde excel, C3 hücresinde de forum yazsın
A1 hücresinde 1, A2 hücresinde de 2 yazsın

Ben şimdi öyle bi kod yazayım ki A5 hücresine ;
1 yazdığımda tablonun 1. satırındaki yani Kaan ve Oğuzu A6 ile B6 hücrelerine yazdırsın
2 yazdığımda tablonun 2. satırındaki yani Excel ve Forumu A6 ile B6 hücrelerine yazdırsın
Anlatması çok zor ve bu yüzden internette çözüm bulamadım yardımcı olursanız sevinirim teşekkürler şimdiden [TESEKKÜR]
Kullanıcı avatarı
Kaan Oğuz
 
Kayıt: 20 May 2018 23:53
Meslek: Öğrenci
Yaş: 18
İleti: 1
 
Cinsiyet: Bay
Bulunduğunuz İl / Semt: tekirdağ

Cevap: Hücredeki veriyi algılayıp tablodan hücre aktarma

İleti#2)  işsiz123 » 21 May 2018 21:34

Ek dosya ekleyip anlatırsanız daha iyi olacağını umuyorum.
Kullanıcı avatarı
işsiz123
Siteye Alışmış
 
Adı Soyadı:Mehmet Emin ALKAN
Kayıt: 16 Kas 2016 17:45
Meslek: YAPI DENETİM
Yaş: 24
İleti: 296
 
Cinsiyet: Bay
Bulunduğunuz İl / Semt: Mardin/Midyat

Cevap: Hücredeki veriyi algılayıp tablodan hücre aktarma

İleti#3)  AhmetRasim » 22 May 2018 15:43

Merhabalar;
Formül ile yapmak isterseniz:
A6 hücresine
Kod: Tümünü seç
=EĞER(A5=1;B2;EĞER(A5=2;B3;""))
B6 Hücresine
Kod: Tümünü seç
=EĞER(A5=1;C2;EĞER(A5=2;C3;""))
formüllerini yazınız.

Kod ile yapmak isterseniz:
Çalışma Sayfanızın kod bölümüne ekleyiniz.
Kod: Tümünü seç
Private Sub Worksheet_Change(ByVal Target As Range)
If Not Intersect(Target, Range("A5")) Is Nothing Then
If Target.Value = 1 Then Target.Offset(1, 0) = [B2].Value
If Target.Value = 1 Then Target.Offset(1, 1) = [C2].Value
If Target.Value = 2 Then Target.Offset(1, 0) = [B3].Value
If Target.Value = 2 Then Target.Offset(1, 1) = [C3].Value
If Target.Value = "" Then Target.Offset(1, 0).Value = ""
If Target.Value = "" Then Target.Offset(1, 1).Value = ""
End If
End Sub
Kullanıcı avatarı
AhmetRasim
Site Dostu
 
Adı Soyadı:Ahmet Rasim
Kayıt: 20 Kas 2013 23:40
Konum: İstanbul
Meslek: Serbest
Yaş: 32
İleti: 981
 
Cinsiyet: Bay


Forum Excel Okulu ile ilgili Soru ve Cevap Alanı

Online Kullanıcılar

Bu forumu görüntüleyenler: Kayıtlı kullanıcı yok ve 1 misafir

Bumerang - Yazarkafe