***** Bu nedir? *****

Excel dersleri ile ilgili sormak istediklerinizi paylaşabileceğiniz alan

Cevap: ***** Bu nedir? *****

İleti#181)  openumt » 24 Mar 2017 20:24

Hocam bir de şu bagıntıda takıldım

=YATAYARA(SOLDAN(E24;3);$D$18:$K$19;2;YANLIŞ)
Kullanıcı avatarı
openumt
Yeni Başlamış
 
Kayıt: 22 Oca 2017 10:26
Meslek: MÜHENDİS
Yaş: 37
İleti: 18
 
Cinsiyet: Bay
Bulunduğunuz İl / Semt: ANKARA

Cevap: ***** Bu nedir? *****

İleti#182)  Ersin Turgut » 24 Mar 2017 22:22

openumt yazdı:Hocam bir de şu bagıntıda takıldım

=YATAYARA(SOLDAN(E24;3);$D$18:$K$19;2;YANLIŞ)



E24 hücresindeki verinin soldan 3 karakterini alarak, D18:K18 arasında aratır, bulursa 19.satırdaki veriyi getirir. :P
Kullanıcı avatarı
Ersin Turgut
Site Dostu
 
Adı Soyadı:Ersin Turgut
Kayıt: 30 Haz 2010 13:17
Konum: İzmir
Meslek: Bilgi İşlem ve Proje Sorumlusu
Yaş: 35
İleti: 602
 
Cinsiyet: Bay
Bulunduğunuz İl / Semt: İzmir / Bornova

Cevap: ***** Bu nedir? *****

İleti#183)  openumt » 25 Mar 2017 20:05

Ersin Turgut yazdı:
openumt yazdı:Hocam bir de şu bagıntıda takıldım

=YATAYARA(SOLDAN(E24;3);$D$18:$K$19;2;YANLIŞ)



E24 hücresindeki verinin soldan 3 karakterini alarak, D18:K18 arasında aratır, bulursa 19.satırdaki veriyi getirir. :P



Teşekkür ederim Ersin bey...müthişsiniz

internette bunlarla ilgili döküman bulamadım ...saygılarıma

smArray

=EĞER(A2="";"";YATAYARA(A2;smArray;2;YANLIŞ))

sYNC2
=EĞER(F14="";"";YATAYARA(F14;sYNC2;2;YANLIŞ))

CurrArray
=EĞER(B8="";"";DÜŞEYARA(B8;CurrArray;4;YANLIŞ))

HM_Calc_Array
=EĞER(B8="";"";DÜŞEYARA(B8;HM_Calc_Array;11;YANLIŞ))

pArray
=TOPLA(EĞER(B9="";"";YATAYARA(B9;pArray;12;YANLIŞ))-EĞER(B9="";"";YATAYARA(B9;pArray;14;YANLIŞ)))
Kullanıcı avatarı
openumt
Yeni Başlamış
 
Kayıt: 22 Oca 2017 10:26
Meslek: MÜHENDİS
Yaş: 37
İleti: 18
 
Cinsiyet: Bay
Bulunduğunuz İl / Semt: ANKARA

Cevap: ***** Bu nedir? *****

İleti#184)  Enes Recep BAĞ » 25 Mar 2017 20:20

Konuyu taşımak zorunda kaldım.
Kullanıcı avatarı
Enes Recep BAĞ
Forum Moderatörü
 
Adı Soyadı:Enes Recep BAĞ
Kayıt: 30 Ağu 2010 15:39
Konum: 0 549 808 82 66
Meslek: Bilgi işlem
Yaş: 37
İleti: 8263
 
Cinsiyet: Bay
Bulunduğunuz İl / Semt: Aksaray / Merkez

REKLAM
Excel Logo XML Oluşturucu
Logo Object Designer ile Uyarlama

Cevap: Cevap: ***** Bu nedir? *****

İleti#185)  openumt » 26 Mar 2017 14:54

Enes Recep BAĞ yazdı:Konuyu taşımak zorunda kaldım.



Enes hocam

Yukarıda ki formulleri yorumlayabilirmisiniz mümkünse tabiki...

iyi çalışmalar
Kullanıcı avatarı
openumt
Yeni Başlamış
 
Kayıt: 22 Oca 2017 10:26
Meslek: MÜHENDİS
Yaş: 37
İleti: 18
 
Cinsiyet: Bay
Bulunduğunuz İl / Semt: ANKARA

Cevap: Cevap: ***** Bu nedir? *****

İleti#186)  alper1907 » 26 Mar 2017 16:51

openumt yazdı:internette bunlarla ilgili döküman bulamadım ...saygılarıma

smArray
=EĞER(A2="";"";YATAYARA(A2;smArray;2;YANLIŞ))

sYNC2
=EĞER(F14="";"";YATAYARA(F14;sYNC2;2;YANLIŞ))

CurrArray
=EĞER(B8="";"";DÜŞEYARA(B8;CurrArray;4;YANLIŞ))

HM_Calc_Array
=EĞER(B8="";"";DÜŞEYARA(B8;HM_Calc_Array;11;YANLIŞ))

pArray
=TOPLA(EĞER(B9="";"";YATAYARA(B9;pArray;12;YANLIŞ))-EĞER(B9="";"";YATAYARA(B9;pArray;14;YANLIŞ)))


Burada yazanlar tanımlanmış alan adları, düşeyara veya yatarara şu şekilde çalışır:
(arancak değer; arama yapılacak alan; verinin bulunduğu satır veya sutun; eşleşme türü)

CTRL+F3 yaparsanız nerelere ait olduğunu görebilirsiniz.
Kullanıcı avatarı
alper1907
Yeni Başlamış
 
Adı Soyadı:Alper Düryaz
Kayıt: 10 Eyl 2010 18:01
Konum: İstanbul
Meslek: İş Güvenliği Uzmanı
Yaş: 34
İleti: 53
 
Cinsiyet: Bay
Bulunduğunuz İl / Semt: Erenköy

REKLAM
ETA - Excel Konsolide Raporlama
ETA Excel Personel Entegre Raporu

Cevap: Cevap: Cevap: ***** Bu nedir? *****

İleti#187)  openumt » 26 Mar 2017 19:09

alper1907 yazdı:
openumt yazdı:internette bunlarla ilgili döküman bulamadım ...saygılarıma

smArray
=EĞER(A2="";"";YATAYARA(A2;smArray;2;YANLIŞ))

sYNC2
=EĞER(F14="";"";YATAYARA(F14;sYNC2;2;YANLIŞ))

CurrArray
=EĞER(B8="";"";DÜŞEYARA(B8;CurrArray;4;YANLIŞ))

HM_Calc_Array
=EĞER(B8="";"";DÜŞEYARA(B8;HM_Calc_Array;11;YANLIŞ))


Teşekkür söylediginiz yaptım görünüyor evet ama örnegin smArray nedir?Herhangi bir hücreye gelin =sm yazdıgınızda smArray çıkıyor bunu anlayamadım ...
pArray
=TOPLA(EĞER(B9="";"";YATAYARA(B9;pArray;12;YANLIŞ))-EĞER(B9="";"";YATAYARA(B9;pArray;14;YANLIŞ)))


Burada yazanlar tanımlanmış alan adları, düşeyara veya yatarara şu şekilde çalışır:
(arancak değer; arama yapılacak alan; verinin bulunduğu satır veya sutun; eşleşme türü)

CTRL+F3 yaparsanız nerelere ait olduğunu görebilirsiniz.
Kullanıcı avatarı
openumt
Yeni Başlamış
 
Kayıt: 22 Oca 2017 10:26
Meslek: MÜHENDİS
Yaş: 37
İleti: 18
 
Cinsiyet: Bay
Bulunduğunuz İl / Semt: ANKARA

Cevap: ***** Bu nedir? *****

İleti#188)  openumt » 01 Nis 2017 08:03

=EĞER(A2="";"";YATAYARA(..

Bunun açıklaması nasıldır...Teşekkür
Kullanıcı avatarı
openumt
Yeni Başlamış
 
Kayıt: 22 Oca 2017 10:26
Meslek: MÜHENDİS
Yaş: 37
İleti: 18
 
Cinsiyet: Bay
Bulunduğunuz İl / Semt: ANKARA

Cevap: ***** Bu nedir? *****

İleti#189)  AhmetRasim » 01 Nis 2017 10:21

Merhabalar;
=EĞER(A2="";"";YATAYARA(..


Eğer A2 hücresi Boş ise (herhangi bir değer yoksa hücrede) sonucu Boş olarak göster, A2 hücresi dolu ise Yatayara formülünün sonucunu göster, olarak tanımlayabiliriz.
Kullanıcı avatarı
AhmetRasim
Site Dostu
 
Adı Soyadı:Ahmet Rasim
Kayıt: 20 Kas 2013 21:40
Konum: İstanbul
Meslek: Serbest
Yaş: 33
İleti: 1133
 
Cinsiyet: Bay

ARKADAŞLAR BU FORMÜLLERİ AÇIKLAYABİLİR MİSİNİZ.

İleti#190)  ferhatgurbuz » 12 Tem 2017 14:35

Sub izintopla()
Sayfa1.Range("A1").Value = ActiveCell.Row
If Sayfa1.Range("A1").Value < 2000 Then
Run "izin2000"
ElseIf Sayfa1.Range("A1").Value <= 2000 And Sayfa1.Range("A1").Value >= 4000 Then
Run "izin4000"
ElseIf Sayfa1.Range("A1").Value > 4000 Then
Run "izin6000"
End If




Sub izin2000()
With Sayfa1
.[O10:O2100] = "=SUMIFS($V$10:$V$2100,$A$10:$A$2100,A10,$Z$10:$Z$2100,$O$8)"
.[O10:O2100].Value = .[O10:O2100].Value
End With
End Sub

Sub izin4000()
With Sayfa1
.[O1900:O4100] = "=SUMIFS($V$1900:$V$4100,$A$1900:$A$4100,A1900,$Z$1900:$Z$4100,$O$8)"
.[O1900:O4100].Value = .[O1900:O4100].Value
End With
End Sub
Sub izin6000()
With Sayfa1
.[O3900:O6000] = "=SUMIFS($V$3900:$V$6000,$A$39000:$A$6000,A3900,$Z$3900:$Z$6000,$O$8)"
.[O3900:O6000].Value = .[O3900:O6000].Value
End With
Kullanıcı avatarı
ferhatgurbuz
 
Kayıt: 11 Tem 2017 15:39
Meslek: özel
Yaş: 40
İleti: 2
 
Cinsiyet: Bay
Bulunduğunuz İl / Semt: İSTANBUL / SANCAKTEPE

Cevap: ***** Bu nedir? *****

İleti#191)  Mesut Topal » 01 Kas 2018 18:09

Do While Not EOF(1)

Bu döngü neyi çeviriyor Arkadaşlar?
Kullanıcı avatarı
Mesut Topal
Siteye Alışmış
 
Kayıt: 15 Eyl 2016 19:19
Meslek: Matematik Öğretmeni
Yaş: 32
İleti: 344
 
Cinsiyet: Bay
Bulunduğunuz İl / Semt: Samsun/Ladik

Cevap: ***** Bu nedir? *****

İleti#192)  Tarkan VURAL » 03 Kas 2018 11:17

Hocam merhaba,

Do while sağlanacak şart
loop

Buradaki sağlanacak şart kısmındaki belirteç ne ise o şarta göre satırlar arası bir döngü oluşacaktır.

Örnek : (Sayısal)
Kod: Tümünü seç
baslangic=1
hedef = 10
Do while baslangic<hedef
işlemler
baslangic = baslangic + 1
loop


Kod parçasına göre, baslangic hedeften küçük olduğu sürece işlemler yapılacaktır.

Örnek : (Recordset)
Kod: Tümünü seç
Do while Not RS.EOF
işlemler
rs.movenext
loop


Kayıtsetindeki konumlandığımız satır, EOF olmadıkça ( End Of Field / Son satır alanı ) döngü işlemleri yapmaya devam edecektir. Burada rs.movenext, sonraki satıra konumlandır demektir. Sonraki satır EOF satırına geldiyse döngüden Loop ile çıkılıp artık aradaki işlemler tekrar yapılmayacaktır.

Örnek : (Sorunuz)

Kod: Tümünü seç
Do while not EOF(1)
işlemler
loop


1 adında bir değişken oluşturulmuş (muhtemelen text dosyası içeriği) ve bu değişkenin satırları arasında dönülüyor. Not EOF ifadesi ile son satıra gelinene dek aradaki işlemler tekrarlanacaktır. EOF gelindiğinde ise son satır işlemi de yapılarak Loop ile döngüden çıkılacaktır.

Dilim döndüğünce izah etmeye çalıştım. Umarım açıklayıcı olmuştur.
Kolay gelsin.
Resim
www.tarkanvural.com.tr

İnnâ lillâhi ve innâ ileyhi raciûn
Şüphesiz ki; biz Allah’a âidiz ve vakti geldiğinde O’na döndürüleceğiz.

HasbunAllâhu ve nimel vekîl
Bize Allah yeter. O ne güzel vekildir.


ExcelVBA.NET' e katkıda bulunmak ister misiniz ? O halde BAĞIŞ butonunu tıklayın...
Kullanıcı avatarı
Tarkan VURAL
Yönetim Kurulu
 
Adı Soyadı:Tarkan VURAL
Kayıt: 14 Haz 2008 18:27
Konum: @tarkanvural73
Meslek: LUU, Database Expert, Senior Software Specialist, Developer
Yaş: 45
İleti: 26998
 
Cinsiyet: Bay
Bulunduğunuz İl / Semt: İstanbul - Beylikdüzü

Cevap: ***** Bu nedir? *****

İleti#193)  Mesut Topal » 04 Kas 2018 09:56

Teşekkürler Hocam. [TESEKKÜR]
Kullanıcı avatarı
Mesut Topal
Siteye Alışmış
 
Kayıt: 15 Eyl 2016 19:19
Meslek: Matematik Öğretmeni
Yaş: 32
İleti: 344
 
Cinsiyet: Bay
Bulunduğunuz İl / Semt: Samsun/Ladik

Cevap: ***** Bu nedir? *****

İleti#194)  Mesut Topal » 22 Kas 2018 18:40

Merhaba Hocalarım,
Bu kodu açıklayabilir misiniz?
Kod: Tümünü seç
bul = s2.Range("C:C").Find(What:=ActiveCell.Value, LookIn:=xlValues, LookAt:=xlWhole, MatchCase:=True).Column
Kullanıcı avatarı
Mesut Topal
Siteye Alışmış
 
Kayıt: 15 Eyl 2016 19:19
Meslek: Matematik Öğretmeni
Yaş: 32
İleti: 344
 
Cinsiyet: Bay
Bulunduğunuz İl / Semt: Samsun/Ladik

Cevap: ***** Bu nedir? *****

İleti#195)  Tarkan VURAL » 23 Kas 2018 09:31

Merhaba. Bu kod parçası CTRL + F ile yaptığınız aramanın aynını gerçekleştiriyor.

S2 olarak tanımlanmış çalışma sayfasının ;
C sütunu tamamında ;
Şu anda üzerinde olduğunuz aktif hücre içeriğindeki değeri (xlValues), tam eşleşme(xlWhole) yaparak sütunda varlığına bakıyor. Varsa muhtemelen sonuç 3 dönecek yoksa 0 / Empty / Null dönecek.
Resim
www.tarkanvural.com.tr

İnnâ lillâhi ve innâ ileyhi raciûn
Şüphesiz ki; biz Allah’a âidiz ve vakti geldiğinde O’na döndürüleceğiz.

HasbunAllâhu ve nimel vekîl
Bize Allah yeter. O ne güzel vekildir.


ExcelVBA.NET' e katkıda bulunmak ister misiniz ? O halde BAĞIŞ butonunu tıklayın...
Kullanıcı avatarı
Tarkan VURAL
Yönetim Kurulu
 
Adı Soyadı:Tarkan VURAL
Kayıt: 14 Haz 2008 18:27
Konum: @tarkanvural73
Meslek: LUU, Database Expert, Senior Software Specialist, Developer
Yaş: 45
İleti: 26998
 
Cinsiyet: Bay
Bulunduğunuz İl / Semt: İstanbul - Beylikdüzü

Cevap: ***** Bu nedir? *****

İleti#196)  AhmetRasim » 23 Kas 2018 09:37

Merhaba Mesut Hocam;
bul = s2.Range("C:C").Find(What:=ActiveCell.Value, LookIn:=xlValues, LookAt:=xlWhole, MatchCase:=True).Column
Satırının bölümleri şu şekilde;
What:=ActiveCell.Value : Aranacak Değer
LookIn:=xlValues : Hücre Değerleri
LookAt:=xlWhole : Tüm hücre içeriğini eşleştir
MatchCase:=True : Büyük/küçük harf duyarlılığı aktif

Anladığım kadarıyla da şu şekilde;
Aktif hücre içeriğini; C sütunundaki hücre değerlerinde büyük/küçük harf duyarlılığı ile tüm hücre eşleşirse bul değişkenine sütun numarasını ver.

Excel 'de bul ekranında da şu şekilde
bul.png
Bu iletideki ekleri görmek için gerekli yetkilere sahip değilsiniz.
Kullanıcı avatarı
AhmetRasim
Site Dostu
 
Adı Soyadı:Ahmet Rasim
Kayıt: 20 Kas 2013 21:40
Konum: İstanbul
Meslek: Serbest
Yaş: 33
İleti: 1133
 
Cinsiyet: Bay

Cevap: ***** Bu nedir? *****

İleti#197)  AhmetRasim » 23 Kas 2018 09:40

Merhabalar Tarkan Bey;
Sizin cevabınızı, gönderince gördüm kusura bakmayın.
Ben anlayıp, yazıp düzenleyene kadar zaman geçiyor. hehe
Kullanıcı avatarı
AhmetRasim
Site Dostu
 
Adı Soyadı:Ahmet Rasim
Kayıt: 20 Kas 2013 21:40
Konum: İstanbul
Meslek: Serbest
Yaş: 33
İleti: 1133
 
Cinsiyet: Bay

Cevap: ***** Bu nedir? *****

İleti#198)  Mesut Topal » 23 Kas 2018 10:48

Çok teşekkürler Kıymetli Arkadaşlar
Kullanıcı avatarı
Mesut Topal
Siteye Alışmış
 
Kayıt: 15 Eyl 2016 19:19
Meslek: Matematik Öğretmeni
Yaş: 32
İleti: 344
 
Cinsiyet: Bay
Bulunduğunuz İl / Semt: Samsun/Ladik

Cevap: ***** Bu nedir? *****

İleti#199)  Tarkan VURAL » 23 Kas 2018 13:03

Estağfurullah Ahmet bey, benim anlattığım kısaydı siz detaylı anlatmışsınız. Elinize, emeğinize sağlık. --)(
Resim
www.tarkanvural.com.tr

İnnâ lillâhi ve innâ ileyhi raciûn
Şüphesiz ki; biz Allah’a âidiz ve vakti geldiğinde O’na döndürüleceğiz.

HasbunAllâhu ve nimel vekîl
Bize Allah yeter. O ne güzel vekildir.


ExcelVBA.NET' e katkıda bulunmak ister misiniz ? O halde BAĞIŞ butonunu tıklayın...
Kullanıcı avatarı
Tarkan VURAL
Yönetim Kurulu
 
Adı Soyadı:Tarkan VURAL
Kayıt: 14 Haz 2008 18:27
Konum: @tarkanvural73
Meslek: LUU, Database Expert, Senior Software Specialist, Developer
Yaş: 45
İleti: 26998
 
Cinsiyet: Bay
Bulunduğunuz İl / Semt: İstanbul - Beylikdüzü

Cevap: ***** Bu nedir? *****

İleti#200)  Mesut Topal » 10 Tem 2019 07:48

Hayırlı günler.

Property Get
Property Let
Property Set

Bu prosedürler ne işe yarar arkadaşlar?
Kullanıcı avatarı
Mesut Topal
Siteye Alışmış
 
Kayıt: 15 Eyl 2016 19:19
Meslek: Matematik Öğretmeni
Yaş: 32
İleti: 344
 
Cinsiyet: Bay
Bulunduğunuz İl / Semt: Samsun/Ladik

Önceki

Forum Excel Okulu ile ilgili Soru ve Cevap Alanı

Online Kullanıcılar

Bu forumu görüntüleyenler: Kayıtlı kullanıcı yok ve 1 misafir

Bumerang - Yazarkafe