Düşeyara formülü hakkında.

VBA Makrolar ile ilgili sormak istedikleriniz, yapmak istedikleriniz hakkında yardım alabileceğiniz bölümdür.

Düşeyara formülü hakkında.

İleti#1)  edayuzer » 11 May 2009 19:47

Merhaba,

Ekteki raporda düşeyara formülünü kullandım fakat verilerin karşılığı gelmiyor.Bakmanız mümkün mü?Kodlar mevcut bilgilerinize...
Teşekkürler
Bu iletideki ekleri görmek için gerekli yetkilere sahip değilsiniz.
Kullanıcı avatarı
edayuzer
Siteye Alışmış
 
Adı Soyadı:eda yuzer
Kayıt: 11 Şub 2009 22:43
İleti: 189
 
Cinsiyet: Bayan
Bulunduğunuz İl / Semt: istanbul

Cevap: Düşeyara formülü hakkında.

İleti#2)  Tarkan VURAL » 11 May 2009 19:51

Merhaba,
Neyi hangi sayfada düşey aradığınızı anlayamadım, soru nedir? [ilginc]
ExcelVBA.NET' e katkıda bulunmak ister misiniz ? O halde BAĞIŞ butonunu tıklayın...


İnnâ lillâhi ve innâ ileyhi raciûn
Şüphesiz ki; biz Allah’a âidiz ve vakti geldiğinde O’na döndürüleceğiz.


www.yazilim.technology
Kullanıcı avatarı
Tarkan VURAL
Yönetim Kurulu
 
Adı Soyadı:Tarkan VURAL
Kayıt: 14 Haz 2008 19:27
Konum: tarkan@excelvba.net
Meslek: LUU, Yazılım Geliştirme Müdürü
Yaş: 41
İleti: 25299
 
Cinsiyet: Bay
Bulunduğunuz İl / Semt: İstanbul - Beylikdüzü

REKLAM

Bumerang - Yazarkafe

Cevap: Düşeyara formülü hakkında.

İleti#3)  edayuzer » 12 May 2009 05:43

"Merchant id " bazında "revenue" sayfasında bulunan aşağıdaki bilgileri liste den düşeyara ile getirmeye çalışıyorum.
"Blokeli/Ertesigün SECTOR BRAND TITLE RM"
Kullanıcı avatarı
edayuzer
Siteye Alışmış
 
Adı Soyadı:eda yuzer
Kayıt: 11 Şub 2009 22:43
İleti: 189
 
Cinsiyet: Bayan
Bulunduğunuz İl / Semt: istanbul

Cevap: Düşeyara formülü hakkında.

İleti#4)  Tarkan VURAL » 12 May 2009 09:40

C2 hücresine;
Kod: Tümünü seç
=DÜŞEYARA(A2;liste!A1:Z4272;3;0)

D2 hücresine;
Kod: Tümünü seç
=DÜŞEYARA(A2;liste!A1:Z4272;2;0)

E2 hücresine ;
Kod: Tümünü seç
=DÜŞEYARA(A2;liste!A1:Z4272;4;0)

F2 hücresine ;
Kod: Tümünü seç
=DÜŞEYARA(A2;liste!A1:Z4272;9;0)


... yazdığınızda verileri alabilirsiniz. Blokeli kısmı ile ilgili verilerin nerede olduğunu bilmediğimden yazamadım.
Düşeyara ile ilgili daha geniş bilgi için Düşeyara formülü yardım açıklamasına başvurunuz.
ExcelVBA.NET' e katkıda bulunmak ister misiniz ? O halde BAĞIŞ butonunu tıklayın...


İnnâ lillâhi ve innâ ileyhi raciûn
Şüphesiz ki; biz Allah’a âidiz ve vakti geldiğinde O’na döndürüleceğiz.


www.yazilim.technology
Kullanıcı avatarı
Tarkan VURAL
Yönetim Kurulu
 
Adı Soyadı:Tarkan VURAL
Kayıt: 14 Haz 2008 19:27
Konum: tarkan@excelvba.net
Meslek: LUU, Yazılım Geliştirme Müdürü
Yaş: 41
İleti: 25299
 
Cinsiyet: Bay
Bulunduğunuz İl / Semt: İstanbul - Beylikdüzü

İleti#5)  Tamer Kılıçaslan » 12 May 2009 10:06

Merhaba

2. seçenek olarak aşağıdaki kodları da deneyebilirsiniz.

Kod: Tümünü seç
Sub F2Enter()
Dim i As Integer
Dim Say As Integer
Say = Sheets("revenue").Range("A30000").End(xlUp).Row
For i = 2 To Say
DoEvents
Cells(i, 1).Select
SendKeys "{F2}{ENTER}"
Next i
End Sub
Kullanıcı avatarı
Tamer Kılıçaslan
Site Dostu
 
Adı Soyadı:Tamer Kılıçaslan
Kayıt: 09 Kas 2008 20:41
Konum: Ege, Office 2003 Tr
Meslek: Tekniker
İleti: 1222
 
Cinsiyet: Bay
Bulunduğunuz İl / Semt: Gediz Kütahya - Düzce

Cevap: Düşeyara formülü hakkında.

İleti#6)  edayuzer » 12 May 2009 21:53

Çok teşekkür ederim.İşimi çok kolaylaştırdınız.


Resûl-i Ekrem Efendimizin, Hz. Muaz ile beraberinde gönderdiği Ebû Mûsa el-Eşarî'yi uğurlarken de son tavsiyesi şu oldu:

"Kolaylaştırınız! Zorlaştırmayınız! Müjdeleyiniz, nefret ettirmeyiniz! Birbirinizle anlaşın, iyi geçinin, ihtilâfa düşmeyin!"
Kullanıcı avatarı
edayuzer
Siteye Alışmış
 
Adı Soyadı:eda yuzer
Kayıt: 11 Şub 2009 22:43
İleti: 189
 
Cinsiyet: Bayan
Bulunduğunuz İl / Semt: istanbul

Cevap: Cevap: Düşeyara formülü hakkında.

İleti#7)  OrkmesB » 12 May 2009 22:33


edayuzer yazdı:"Kolaylaştırınız! Zorlaştırmayınız! Müjdeleyiniz, nefret ettirmeyiniz! Birbirinizle anlaşın, iyi geçinin, ihtilâfa düşmeyin!"


Benim burada bir katkım yok.
Ama forum yöneticilerine peygamber efendimizin hadis-i şerif'i ile atıfta bulunmanız çok güzel ve anlamlı olmuş.
Ben de arkadaşlarımı tebrik ederim.
Allah'ın selamı üzerinize olsun.

OrkmesB
Yönetim Kurulu
 
Bumerang - Yazarkafe
Adı Soyadı:Bahadır Örkmes
Kayıt: 14 Haz 2008 23:50
Konum: Perfetti Van Melle
Meslek: Personel Müdürü
Yaş: 36
İleti: 4685
 
Cinsiyet: Bay

İleti#8)  Tamer Kılıçaslan » 12 May 2009 23:28

Tamer Kılıçaslan yazdı:...2. seçenek olarak aşağıdaki kodları da deneyebilirsiniz.


Mesajı gönderirken zamanım kısıtlıydı. Bu nedenle açıklama yazamamıştım.
Eda hanım'ın eklemiş olduğu örnek dosyada, muhtemelen, Tarkan beyin daha önceden yazdığı, Worksheet_Change olayına yazılmış VLookup (Düşeyara) kodları mevcuttu. Sayfadaki veriler başka bir yerden kopyalanarak yada kodlar vasıtası ile alındığı için kodlar tetiklenmemiş halde kalıyordu.
Kodları harekete geçirmek için, A2:A1658 aralığındaki hücrelere ya, tek tek girip Enter tuşuna basılacak yada bu işlem kod ile yapılacaktı.
Eklemiş olduğum kodların, yapmış olduğu işlem, kısaca, F2+Enter tuşuna basma işlemi. Süre olarak 15 sn. tutuyor.

edayuzer yazdı:Çok teşekkür ederim. İşimi çok kolaylaştırdınız...

Rica ederiz. Sizlerin işinin kolaylaşmış olması bizleri de aynı derece memnun eder.
İnşallah Allah (c.c) bizim işlerimizi de kolaylaştırır.
Kullanıcı avatarı
Tamer Kılıçaslan
Site Dostu
 
Adı Soyadı:Tamer Kılıçaslan
Kayıt: 09 Kas 2008 20:41
Konum: Ege, Office 2003 Tr
Meslek: Tekniker
İleti: 1222
 
Cinsiyet: Bay
Bulunduğunuz İl / Semt: Gediz Kütahya - Düzce


Forum Genel Makro Soruları

Online Kullanıcılar

Bu forumu görüntüleyenler: muratvural ve 0 misafir

Bumerang - Yazarkafe