1 sayfadan 1. sayfa

Bir Rakamı Alt Alta Yazdırma ve Hafta Sonu Sayısı

İletiTarih: 07 Mar 2018 11:25
teyadih
Kolay gelsin arkadaşlar 2 formüle ihtiyacım var
1- A1 e yazdığım rakamı 1 den başlayarak B2 den itibaren aşağıya doğru yazdıracak bir formüle ihtiyacım var
Örnek A1 deki 40 rakamını 1 den başlayacak 40 da bitirecek

2- D sütununda bulunan tarihlerde kaç tane hafta sonu yani cumartesi pazar olduğunu verecek formül

Teşekkür ederim

Cevap: Bir Rakamı Alt Alta Yazdırma ve Hafta Sonu Sayısı

İletiTarih: 07 Mar 2018 12:08
hemso41
Bunları yapacak formül bulmak çok zor. Onun yerine sayfanın change yordamına aşağıdaki kodu eklemeniz yeterli olacaktır.
Kod: Tümünü seç
Private Sub Worksheet_Change(ByVal Target As Range)

    If Target.Address = "$A$1" Then
    son = Range("d1").End(xlDown).Row
    Range("B:B").Clear
        For i = 1 To Range("a1").Value
            Cells(i, 2) = i
        Next
           
                For j = 1 To son
                    If Weekday(Cells(j, 4), vbMonday) = 6 Or Weekday(Cells(j, 4), vbMonday) = 7 Then
                        toplam = toplam + 1
                    End If
                Next
        MsgBox toplam & "adet haftasonuna denk gelen gün var"
    End If
   
   
End Sub




Cevap: Bir Rakamı Alt Alta Yazdırma ve Hafta Sonu Sayısı

İletiTarih: 07 Mar 2018 12:16
Ali Kırksekiz
A1 e yazdığım rakamı 1 den başlayarak B2 den itibaren aşağıya doğru yazdıracak bir formüle ihtiyacım var
Örnek A1 deki 40 rakamını 1 den başlayacak 40 da bitirecek


A1 sayıyı'yı yazın B1 hücresine aşağıdakini yazıp aşağı doğru çekiniz.

Kod: Tümünü seç
=EĞER(SATIRSAY($B$1:B1)>$A$1;"";SATIRSAY($B$1:B1))



D sütununda bulunan tarihlerde kaç tane hafta sonu yani cumartesi pazar olduğunu verecek formül


Kod: Tümünü seç
=TOPLA.ÇARPIM(--(HAFTANINGÜNÜ(D2:D100;2)>5)*(D2:D100<>""))


yazınız.

Cevap: Bir Rakamı Alt Alta Yazdırma ve Hafta Sonu Sayısı

İletiTarih: 07 Mar 2018 13:27
hemso41
Ali bey çok zor demiştim geri alıyorum sözümü.Ellerinize sağlık.

Cevap: Cevap: Bir Rakamı Alt Alta Yazdırma ve Hafta Sonu Say

İletiTarih: 07 Mar 2018 15:04
Ali Kırksekiz
hemso41 yazdı:Ali bey çok zor demiştim geri alıyorum sözümü.Ellerinize sağlık.


Sizinde ellerinize sağlık. --)(

Cevap: Bir Rakamı Alt Alta Yazdırma ve Hafta Sonu Sayısı

İletiTarih: 07 Mar 2018 15:37
Murat OSMA
İlk isteğe alternatif olarak bu formülü de kullanabilirsiniz..

Kod: Tümünü seç
=($A$1>=SATIR())*SATIR()

Hücre Biçimlendirmeden İsteğe Uyarlanmışı seçin, Tür kısmına da 0;; yazıp Tamam deyin..

Cevap: Bir Rakamı Alt Alta Yazdırma ve Hafta Sonu Sayısı

İletiTarih: 26 Haz 2018 14:49
teyadih
Teşekkür ederim arkadaşlar kusura bakmayın geç dönüş yaptım.

Cevap: Bir Rakamı Alt Alta Yazdırma ve Hafta Sonu Sayısı

İletiTarih: 11 Tem 2018 09:56
teyadih
Sayın Ali Kırksekiz. Yazmış olduğunuz
=EĞER(SATIRSAY($B$1:B1)>$A$1;"";SATIRSAY($B$1:B1)) formülü 1 den başlayış 40 a kadar gidiyor bunu tam tersi 40 dan başlayış 0 a kadar düşecek şekilde,
=TOPLA.ÇARPIM(--(HAFTANINGÜNÜ(D2:D100;2)>5)*(D2:D100<>"")) formülünü ise D sütunundaki hafta sonları ile E sütununda bulunan resmi tatil tarihlerin toplamını verecek şekilde yapabilir misiniz rica etsem.

Cevap: Cevap: Bir Rakamı Alt Alta Yazdırma ve Hafta Sonu Say

İletiTarih: 12 Tem 2018 10:27
Ali Kırksekiz
teyadih yazdı:Sayın Ali Kırksekiz. Yazmış olduğunuz
=EĞER(SATIRSAY($B$1:B1)>$A$1;"";SATIRSAY($B$1:B1)) formülü 1 den başlayış 40 a kadar gidiyor bunu tam tersi 40 dan başlayış 0 a kadar düşecek şekilde,


Kod: Tümünü seç
=EĞER(SATIRSAY($B$1:B1)>$A$1;"";$A$1-SATIRSAY($B$1:B1)+1)


teyadih yazdı:=TOPLA.ÇARPIM(--(HAFTANINGÜNÜ(D2:D100;2)>5)*(D2:D100<>"")) formülünü ise D sütunundaki hafta sonları ile E sütununda bulunan resmi tatil tarihlerin toplamını verecek şekilde yapabilir misiniz rica etsem.


E sütununda sadece resmi tatiller olsun.

Kod: Tümünü seç
=TOPLA.ÇARPIM(--(HAFTANINGÜNÜ(D2:D100;2)>5)*(D2:D100<>""))+BAĞ_DEĞ_DOLU_SAY(E2:E100)

Cevap: Bir Rakamı Alt Alta Yazdırma ve Hafta Sonu Sayısı

İletiTarih: 12 Tem 2018 15:12
teyadih
Teşekkür ederim sayın ali kırksekiz elinize sağlık. Resmi tatil günlerinin eklenmesiyle ilgili eksik bilgi vermişim kusura bakmayın. Belirtilen tarihler arasındaki hafta sonları ile resmi tatil sayısını verecek bir formüle ihtiyacım var. Örnek belgeyi ekte gönderiyorum.
teşekkür ederim tekrar

Cevap: Bir Rakamı Alt Alta Yazdırma ve Hafta Sonu Sayısı

İletiTarih: 12 Tem 2018 16:40
teyadih
Ali bey sizi yoruyorum hakkınızı helal edin son yaptığınız formülü =EĞERHATA(EĞER(SATIRSAY(E1:E1)>E1;"0";E1-SATIRSAY(E1:E1)-2);) bu şekilde yaparak 3 er 3 er düşmesi şeklinde ayarladım ancak ilk yaptığınız =EĞER(SATIRSAY($B$1:B1)>$A$1;"";SATIRSAY($B$1:B1)) formülünü 40 a kadar 3 er 3 er atmasını yapamadım. Size zahmet buna da bakar mısınız

Cevap: Bir Rakamı Alt Alta Yazdırma ve Hafta Sonu Sayısı

İletiTarih: 13 Tem 2018 15:39
Ali Kırksekiz
Kod: Tümünü seç
=EĞER(SATIRSAY($B$1:$B1)*3-3+1>$A$1;"";SATIRSAY($B$1:$B1)*3-3+1)

Cevap: Bir Rakamı Alt Alta Yazdırma ve Hafta Sonu Sayısı

İletiTarih: 13 Tem 2018 19:26
teyadih
Teşekkür ederim ali bey pazartesi işe gittiğimde deneyeceğim formülü
Gönderdiğim dosyayı inceleyebildiniz mi acaba

Cevap: Bir Rakamı Alt Alta Yazdırma ve Hafta Sonu Sayısı

İletiTarih: 16 Tem 2018 09:58
teyadih
Sıkıntı yok ali bey elinize sağlık.