[Yardım]  Sayfada belirli kelimede komşu hücredeki değeri hesaplama

VBA Makrolar ile ilgili sormak istedikleriniz, yapmak istedikleriniz hakkında yardım alabileceğiniz bölümdür.

Sayfada belirli kelimede komşu hücredeki değeri hesaplama

İleti#1)  Nagihan60 » 20 Tem 2018 23:22

İyi akşamlar,

bir Sayfa üzeri hesaplamada desteğinize ihtiyacım var.

Örneğin: Sütün ("B1:B35")aralığında farklı kelimeler yazılı, Sütün ("L1:L35") aralığında Rakamlar yazılı
Sorun: Sütün "B" aralığında herhangi bir hücreye "Yakıt" kelimesi yazıldığında aynı satır üzerindeki (L) sütündeki hücredeki mevcut rakamdan 17% ekşi hesaplaması.


Şimdiden teşekkürler
Kullanıcı avatarı
Nagihan60
Yeni Başlamış
 
Adı Soyadı:Nagihan Ünsal
Kayıt: 09 Kas 2012 23:10
Konum: Müdür Yardımcısı
Meslek: Muhasebe
Yaş: 58
İleti: 30
 
Cinsiyet: Bayan
Bulunduğunuz İl / Semt: Konya

Cevap: Sayfada belirli kelimede komşu hücredeki değeri hesap

İleti#2)  Nagihan60 » 20 Tem 2018 23:32

Not: Bu işlem için makroya ihtiyacım var, çünkü ("L1:L35") arası başka bir işlem için zaten formül mevcut.
Kullanıcı avatarı
Nagihan60
Yeni Başlamış
 
Adı Soyadı:Nagihan Ünsal
Kayıt: 09 Kas 2012 23:10
Konum: Müdür Yardımcısı
Meslek: Muhasebe
Yaş: 58
İleti: 30
 
Cinsiyet: Bayan
Bulunduğunuz İl / Semt: Konya

Cevap: Sayfada belirli kelimede komşu hücredeki değeri hesap

İleti#3)  ozgeyanpar » 21 Tem 2018 11:53

Merhaba L1:L35 arasındaki sayının %17 çıkarılmış halini yazan makro böyle. doğru anladım değil mi?
Kod: Tümünü seç
Sub deneme()

For i = 1 To 35
sayi = Cells(i, 12) * (0.17)
Cells(i, 12) = Cells(i, 12) - sayi
Next


End Sub
Kullanıcı avatarı
ozgeyanpar
Yeni Başlamış
 
Kayıt: 28 Ekm 2017 19:59
Meslek: Öğrenci
Yaş: 22
İleti: 10
 
Cinsiyet: Bayan
Bulunduğunuz İl / Semt: Eskişehir

Cevap: Cevap: Sayfada belirli kelimede komşu hücredeki değer

İleti#4)  Nagihan60 » 21 Tem 2018 16:09

ozgeyanpar yazdı:Merhaba L1:L35 arasındaki sayının %17 çıkarılmış halini yazan makro böyle. doğru anladım değil mi?
Kod: Tümünü seç
Sub deneme()

For i = 1 To 35
sayi = Cells(i, 12) * (0.17)
Cells(i, 12) = Cells(i, 12) - sayi
Next


End Sub

Merhaba,

Özge hanım konuyla ilgilendiğiniz için teşekkürler. Yalnız bu 17% çıkarılması aynı satır üzerinde (B)sütun üzeri (B1:B35) aralığında da hangi hücreye "Yakıt" yazıldığında hesaplaması gerek.

Örneğin: "B12" hücresinde "Yedek" kelimesi yazılı aynı satırda "L12" 125 rakamı yazıyor burada bir işlem yapılması gerekmiyor
"B13" hücresinde "Yakıt"(kelimesi yazıldığında) aynı satırda "L13" mevcut olan rakamdan anında (17%) çıkarılmış vaziyete göstermesi gerekli.

Sanırım burda Private Sub Worksheet_Change(ByVal Target Aş Range) gerekli olacaktır.
Kullanıcı avatarı
Nagihan60
Yeni Başlamış
 
Adı Soyadı:Nagihan Ünsal
Kayıt: 09 Kas 2012 23:10
Konum: Müdür Yardımcısı
Meslek: Muhasebe
Yaş: 58
İleti: 30
 
Cinsiyet: Bayan
Bulunduğunuz İl / Semt: Konya

REKLAM
Excel Logo XML Oluşturucu
Logo Object Designer ile Uyarlama

Cevap: Sayfada belirli kelimede komşu hücredeki değeri hesap

İleti#5)  tasad » 22 Tem 2018 19:53

("L1:L35") arası başka bir işlem için zaten formül mevcut demişsiniz.
Formülü yazın yada örnek dosya ekleyin,kodunu yazalım.
Kullanıcı avatarı
tasad
Siteye Alışmış
 
Kayıt: 04 Şub 2018 11:46
Meslek: muhasebeci
Yaş: 26
İleti: 174
 
Cinsiyet: Bay
Bulunduğunuz İl / Semt: ısparta

Cevap: Cevap: Sayfada belirli kelimede komşu hücredeki değer

İleti#6)  Nagihan60 » 23 Tem 2018 21:49

tasad yazdı:("L1:L35") arası başka bir işlem için zaten formül mevcut demişsiniz.
Formülü yazın yada örnek dosya ekleyin,kodunu yazalım.



=EĞER(K1>0;EĞER(B1="yedek";DÜŞEYARA(K1;Sayfa2!A:C;3;YANLIŞ);EĞER(B1="ürün";0;EĞER(C1="Liste";DÜŞEYARA(P1;Liste;6;YANLIŞ)*0,5;DÜŞEYARA(H1;Liste;6;YANLIŞ))));0)
Kullanıcı avatarı
Nagihan60
Yeni Başlamış
 
Adı Soyadı:Nagihan Ünsal
Kayıt: 09 Kas 2012 23:10
Konum: Müdür Yardımcısı
Meslek: Muhasebe
Yaş: 58
İleti: 30
 
Cinsiyet: Bayan
Bulunduğunuz İl / Semt: Konya

REKLAM
ETA - Excel Konsolide Raporlama
ETA Excel Personel Entegre Raporu

Cevap: Cevap: Cevap: Sayfada belirli kelimede komşu hücredek

İleti#7)  Nagihan60 » 23 Tem 2018 21:51

Nagihan60 yazdı:
tasad yazdı:("L1:L35") arası başka bir işlem için zaten formül mevcut demişsiniz.
Formülü yazın yada örnek dosya ekleyin,kodunu yazalım.



=EĞER(K1>0;EĞER(B1="yedek";DÜŞEYARA(K1;Sayfa2!A:C;3;YANLIŞ);
EĞER(B1="ürün";0;EĞER(C1="Liste";DÜŞEYARA(P1;Liste;6;YANLIŞ)*0,5;
DÜŞEYARA(H1;Liste;6;YANLIŞ))));0)
Kullanıcı avatarı
Nagihan60
Yeni Başlamış
 
Adı Soyadı:Nagihan Ünsal
Kayıt: 09 Kas 2012 23:10
Konum: Müdür Yardımcısı
Meslek: Muhasebe
Yaş: 58
İleti: 30
 
Cinsiyet: Bayan
Bulunduğunuz İl / Semt: Konya

Cevap: Sayfada belirli kelimede komşu hücredeki değeri hesap

İleti#8)  tasad » 23 Tem 2018 22:24

Örnek bir dosya eklerseniz daha iyi olur.Yazdığınız formülden pek bir şey anlaşılmıyor.
Kullanıcı avatarı
tasad
Siteye Alışmış
 
Kayıt: 04 Şub 2018 11:46
Meslek: muhasebeci
Yaş: 26
İleti: 174
 
Cinsiyet: Bay
Bulunduğunuz İl / Semt: ısparta

Cevap: Cevap: Sayfada belirli kelimede komşu hücredeki değer

İleti#9)  Nagihan60 » 24 Tem 2018 13:47

tasad yazdı:Örnek bir dosya eklerseniz daha iyi olur.Yazdığınız formülden pek bir şey anlaşılmıyor.



Farklı bir hücreye ilave formül yazılarak sorun çözülmüştür.

Yinede çok teşekkürler.
Kullanıcı avatarı
Nagihan60
Yeni Başlamış
 
Adı Soyadı:Nagihan Ünsal
Kayıt: 09 Kas 2012 23:10
Konum: Müdür Yardımcısı
Meslek: Muhasebe
Yaş: 58
İleti: 30
 
Cinsiyet: Bayan
Bulunduğunuz İl / Semt: Konya


Forum Genel Makro Soruları

Online Kullanıcılar

Bu forumu görüntüleyenler: Google [Bot], Yandex[Bot] ve 5 misafir

cron
Bumerang - Yazarkafe