[Yardım]  Son alınan net fiyat

VBA Makrolar ile ilgili sormak istedikleriniz, yapmak istedikleriniz hakkında yardım alabileceğiniz bölümdür.

Son alınan net fiyat

İleti#1)  emiroglu07 » 05 Ekm 2018 10:52

Üstadlar elimdeki dosyanın 2018 sayfasındaki verilen sayfa1 sayfasındaki satırdaki değere göre en son alınan fiyatın gelmesini nasıl sağlarım formülde olur makroda olur.
Bu iletideki ekleri görmek için gerekli yetkilere sahip değilsiniz.
Kullanıcı avatarı
emiroglu07
Siteye Alışmış
 
Adı Soyadı:AHMET
Kayıt: 07 Oca 2014 18:36
Konum: İSTANBUL
Meslek: TEKSTİL
Yaş: 31
İleti: 471
 
Cinsiyet: Bay
Bulunduğunuz İl / Semt: DİDİM

Cevap: Son alınan net fiyat

İleti#2)  emiroglu07 » 05 Ekm 2018 14:52

Kod: Tümünü seç
=TOPLA.ÇARPIM((AFD!$I$2:$I$65536=C2)*(AFD!$M$2:$M$65536)*(AFD!$E$2:$E$65536=MAK(EĞER(C2=AFD!$I$2:$I$65536;AFD!$E$2:$E$65536))))

Kod: Tümünü seç
=TOPLA.ÇARPIM((SFD!$I$2:$I$65536=C2)*(SFD!$M$2:$M$65536)*(SFD!$E$2:$E$65536=MAK(EĞER(C2=SFD!$I$2:$I$65536;SFD!$E$2:$E$65536))))

üstadlar bayağı bir uğraştan sonra buldum bu formülü makro şeklinde nasıl yaza bilirim.
Kullanıcı avatarı
emiroglu07
Siteye Alışmış
 
Adı Soyadı:AHMET
Kayıt: 07 Oca 2014 18:36
Konum: İSTANBUL
Meslek: TEKSTİL
Yaş: 31
İleti: 471
 
Cinsiyet: Bay
Bulunduğunuz İl / Semt: DİDİM

Cevap: Son alınan net fiyat

İleti#3)  Ozan İLGÜN » 05 Ekm 2018 15:47

Kod: Tümünü seç
Sub verilerigetir()
Dim i As Integer
For i = 2 To 17

Sayfa1.Range("A1").AutoFilter _
Field:=3, _
Criteria1:=Sayfa2.Range("A" & i).Value
With Sayfa1.UsedRange.SpecialCells(xlCellTypeVisible)
Dim x() As String
Dim count As Integer

x = Split(.Address, "$")

count = UBound(x) - 4

Sayfa2.Range("B" & i).NumberFormat = "dd.mm.yyyy"
Sayfa2.Range("B" & i).Formula = CDate(.Range("A" & Val(x(count))).Formula)
End With

Next i
Sayfa1.Cells.AutoFilter
End Sub
ozan.ilgun@boun.edu.tr

Resim
Kullanıcı avatarı
Ozan İLGÜN
Forum Moderatörü
 
Adı Soyadı:Ozan İlgün
Kayıt: 20 Şub 2013 14:43
Konum: İst. Maltepe
Meslek: Arşivist
Yaş: 32
İleti: 2666
 
Cinsiyet: Bay
Bulunduğunuz İl / Semt: İstanbul



Cevap: Son alınan net fiyat

İleti#4)  emiroglu07 » 05 Ekm 2018 16:03

ozan bey yardımınıza teşekkür ederim ama topla çarpım formulu ile pek uyuşmuyor bu makro. [ilginc]
Kullanıcı avatarı
emiroglu07
Siteye Alışmış
 
Adı Soyadı:AHMET
Kayıt: 07 Oca 2014 18:36
Konum: İSTANBUL
Meslek: TEKSTİL
Yaş: 31
İleti: 471
 
Cinsiyet: Bay
Bulunduğunuz İl / Semt: DİDİM

REKLAM
Excel Logo XML Oluşturucu
Logo Object Designer ile Uyarlama

Cevap: Son alınan net fiyat

İleti#5)  Ali Kırksekiz » 05 Ekm 2018 18:10

Sayfa1 B2 hücresine

Kod: Tümünü seç
=ARA(2;1/('2018 ALIŞ'!$C$2:$C$6300=A2);'2018 ALIŞ'!$G$2:$G$6300)


yazıp aşağı doğru çekiniz.
Ali Kırksekiz
Forum Moderatörü
 
Adı Soyadı:Ali Kırksekiz
Kayıt: 18 Eyl 2008 09:12
Konum: Sivas
Meslek: Lab ve Kalite Kontrol
Yaş: 44
İleti: 1552
 
Cinsiyet: Bay
Bulunduğunuz İl / Semt: Sivas

Cevap: Son alınan net fiyat

İleti#6)  emiroglu07 » 07 Ekm 2018 00:27

Kod: Tümünü seç
=ARA(2;1/(AFD!I2:I9=STOK!C2);AFD!M2:M11)
ali bey bu formülü makroda gösterebilirmiyiz.
Kullanıcı avatarı
emiroglu07
Siteye Alışmış
 
Adı Soyadı:AHMET
Kayıt: 07 Oca 2014 18:36
Konum: İSTANBUL
Meslek: TEKSTİL
Yaş: 31
İleti: 471
 
Cinsiyet: Bay
Bulunduğunuz İl / Semt: DİDİM

REKLAM
ETA - Excel Konsolide Raporlama
ETA Excel Personel Entegre Raporu

Cevap: Son alınan net fiyat

İleti#7)  emiroglu07 » 11 Ekm 2018 10:32

Üstadlar bu konu ile ilgili bir makro önere bilirmisiniz bir türlü çıkamadım işin içinden.
Kullanıcı avatarı
emiroglu07
Siteye Alışmış
 
Adı Soyadı:AHMET
Kayıt: 07 Oca 2014 18:36
Konum: İSTANBUL
Meslek: TEKSTİL
Yaş: 31
İleti: 471
 
Cinsiyet: Bay
Bulunduğunuz İl / Semt: DİDİM

Cevap: Son alınan net fiyat

İleti#8)  hemso41 » 11 Ekm 2018 17:15

ALIŞ FATURA LİSTESİ.rar
Makroya gerek yok.Ekteki gibi yapılabilir.
Bu iletideki ekleri görmek için gerekli yetkilere sahip değilsiniz.
Kullanıcı avatarı
hemso41
Siteye Alışmış
 
Kayıt: 22 Eyl 2015 10:04
Meslek: BİLGİ İŞLEM
Yaş: 38
İleti: 364
 
Cinsiyet: Bay
Bulunduğunuz İl / Semt: izmir/karşıyaka

Cevap: Son alınan net fiyat

İleti#9)  emiroglu07 » 11 Ekm 2018 17:55

üstad ben bunu listboxda göstericem stok adı olup son alış tutaur olmayanları yok olarak gösteriyor listbox dada bu hata olarak veriyor yada yoksa 0 göster seklinde bir formul olmalı.
Kullanıcı avatarı
emiroglu07
Siteye Alışmış
 
Adı Soyadı:AHMET
Kayıt: 07 Oca 2014 18:36
Konum: İSTANBUL
Meslek: TEKSTİL
Yaş: 31
İleti: 471
 
Cinsiyet: Bay
Bulunduğunuz İl / Semt: DİDİM


Forum Genel Makro Soruları

Online Kullanıcılar

Bu forumu görüntüleyenler: Kayıtlı kullanıcı yok ve 4 misafir

Bumerang - Yazarkafe