[Çözüldü]  Ado ile Son Alış Fiyatı

VBA Makrolar ile ilgili sormak istedikleriniz, yapmak istedikleriniz hakkında yardım alabileceğiniz bölümdür.

Ado ile Son Alış Fiyatı

İleti#1)  emiroglu07 » 12 Oca 2019 08:37

Bu formüller bir makro yada ado ya çevrile bilir mi bu konuda yardımcı olabilirmisiniz.

Kod: Tümünü seç
ÇOKETOPLA(DETAY!$H$3:$H$65520;DETAY!$C$3:$C$65520;$J$1;DETAY!$G$3:$G$65520;A2)
=ÇOKETOPLA(DETAY!$H$3:$H$65520;DETAY!$C$3:$C$65520;$K$1;DETAY!$G$3:$G$65520;A2)
=ÇOKETOPLA(TEKNE!$F$7:$F$65516;TEKNE!$C$7:$C$65516;$M$1;TEKNE!$E$7:$E$65516;A2)
=MAK(EĞER(DETAY!G:G=STOK!A2;DETAY!J:J))
=MAK(EĞER(DETAY!G:G=STOK!A2;DETAY!P:P))
En son Vedat ÖZER tarafından, 12 Mar 2019 15:37 tarihinde değiştirildi, toplamda 1 değişiklik yapıldı.
Sebep: Yazım Düzeni
Kullanıcı avatarı
emiroglu07
Site Dostu
 
Adı Soyadı:AHMET
Kayıt: 07 Oca 2014 16:36
Konum: İSTANBUL
Meslek: TEKSTİL
Yaş: 32
İleti: 503
 
Cinsiyet: Bay
Bulunduğunuz İl / Semt: DİDİM

Cevap: Formul Makro Yada Ado Oluşturma

İleti#2)  askmadige34 » 12 Oca 2019 11:53

Örnek dosyanızı eklerseniz çözüm konusunda daha çabuk yardım alırsınız.
askmadige34
Forum Moderatörü
 
Kayıt: 20 Kas 2015 11:04
Meslek: memur
Yaş: 38
İleti: 1690
 
Cinsiyet: Bay
Bulunduğunuz İl / Semt: Kayseri

Cevap: Formul Makro Yada Ado Oluşturma

İleti#3)  emiroglu07 » 12 Oca 2019 12:16

Üstad işlem yapmak istediğim formüller stok sayfasın da son alış sutunların formülleri yazılı değil çok kasma yapıyor onun yerine açıklama olarak kaydettim lazım olduğu zaman kopyalayıp yapıştırıyorum.
Bu iletideki ekleri görmek için gerekli yetkilere sahip değilsiniz.
Kullanıcı avatarı
emiroglu07
Site Dostu
 
Adı Soyadı:AHMET
Kayıt: 07 Oca 2014 16:36
Konum: İSTANBUL
Meslek: TEKSTİL
Yaş: 32
İleti: 503
 
Cinsiyet: Bay
Bulunduğunuz İl / Semt: DİDİM

Cevap: Formul Makro Yada Ado Oluşturma

İleti#4)  emiroglu07 » 06 Şub 2019 10:43

[code]=MAK(EĞER(DETAY!G:G=STOK!A2;DETAY!J:J))
=MAK(EĞER(DETAY!G:G=STOK!A2;DETAY!P:P))[code]
Üstadlar sadece bu formülün işleyeceği bir makro nasıl yapılabilir?
Kullanıcı avatarı
emiroglu07
Site Dostu
 
Adı Soyadı:AHMET
Kayıt: 07 Oca 2014 16:36
Konum: İSTANBUL
Meslek: TEKSTİL
Yaş: 32
İleti: 503
 
Cinsiyet: Bay
Bulunduğunuz İl / Semt: DİDİM

REKLAM
Excel Logo XML Oluşturucu
Logo Object Designer ile Uyarlama

Cevap: Formul Makro Yada Ado Oluşturma

İleti#5)  Vedat ÖZER » 19 Şub 2019 16:26

Selamlar

Aşağıdaki kodu deneyebilir misiniz.

Kod: Tümünü seç
Sub SONALIS()
   
    Dim son_satir&
    Zaman = Timer
    With Application
    .ScreenUpdating = False
    End With

    Set con = VBA.CreateObject("adodb.Connection")
    Set rs = VBA.CreateObject("adodb.Recordset")
    con.Open "provider=microsoft.ace.oledb.12.0;data source=" & _
    ThisWorkbook.FullName & ";extended properties=""Excel 12.0;hdr=no"""
    Range("N2:N" & Rows.Count).ClearContents
   
    son_satir = Cells(Rows.Count, "b").End(3).Row
   
    For i = 2 To son_satir
    Set rs = VBA.CreateObject("adodb.Recordset")
    KODU = Range("b" & i).Value
    sorgu = "SELECT TOP 1 LAST(F10),LAST(F16) from [DETAY$] where f6 = '" & KODU & "' order by LAST(f1)DESC "
    rs.Open sorgu, con
    Range("N" & i).CopyFromRecordset rs
    sorgu = Empty
    Next i
   
    son_satir = Empty
   
    With Application
    .ScreenUpdating = True
    End With
    MsgBox "İşleminiz Tamamlanmıştır. " & Chr(10) & Chr(10) & _
           "İşlem süresi ; " & Format((Timer - Zaman) / 60, "0.00") & " Saniye", vbInformation, "VEDAT ÖZER"
End Sub
حَسْبُنَا اللهُ وَنِعْمَ الْوَكِيلُ
Allah bize yeter, O ne güzel vekildir.

vedatozer@outlook.com
Vedat ÖZER
Forum Moderatörü
 
Adı Soyadı:vedat özer
Kayıt: 12 Haz 2014 15:26
Konum: ANTALYA / KEMER
Meslek: MUHASEBE
Yaş: 28
İleti: 598
 
Cinsiyet: Bay
Bulunduğunuz İl / Semt: Antalya

Cevap: Ado ile Son Alış Fiyatı

İleti#6)  emiroglu07 » 11 Mar 2019 13:53

Üstad Bunu denedim ben donup kalıyor herhangi bir şey yapmıyor.
Kullanıcı avatarı
emiroglu07
Site Dostu
 
Adı Soyadı:AHMET
Kayıt: 07 Oca 2014 16:36
Konum: İSTANBUL
Meslek: TEKSTİL
Yaş: 32
İleti: 503
 
Cinsiyet: Bay
Bulunduğunuz İl / Semt: DİDİM

REKLAM
ETA - Excel Konsolide Raporlama
ETA Excel Personel Entegre Raporu

Cevap: Ado ile Son Alış Fiyatı

İleti#7)  Vedat ÖZER » 11 Mar 2019 16:52

Merhaba,

Dosya ekte deneyebilir misiniz.
Bu iletideki ekleri görmek için gerekli yetkilere sahip değilsiniz.
حَسْبُنَا اللهُ وَنِعْمَ الْوَكِيلُ
Allah bize yeter, O ne güzel vekildir.

vedatozer@outlook.com
Vedat ÖZER
Forum Moderatörü
 
Adı Soyadı:vedat özer
Kayıt: 12 Haz 2014 15:26
Konum: ANTALYA / KEMER
Meslek: MUHASEBE
Yaş: 28
İleti: 598
 
Cinsiyet: Bay
Bulunduğunuz İl / Semt: Antalya

Cevap: Ado ile Son Alış Fiyatı

İleti#8)  emiroglu07 » 12 Mar 2019 11:53

Vedat bey çok teşekkür ederim çok güzel olmuş elinize emeğinize sağlık. şkşk
Kullanıcı avatarı
emiroglu07
Site Dostu
 
Adı Soyadı:AHMET
Kayıt: 07 Oca 2014 16:36
Konum: İSTANBUL
Meslek: TEKSTİL
Yaş: 32
İleti: 503
 
Cinsiyet: Bay
Bulunduğunuz İl / Semt: DİDİM

Cevap: Ado ile Son Alış Fiyatı

İleti#9)  Vedat ÖZER » 12 Mar 2019 15:37

Rica Ederim,
İyi çalışmalar dilerim.
حَسْبُنَا اللهُ وَنِعْمَ الْوَكِيلُ
Allah bize yeter, O ne güzel vekildir.

vedatozer@outlook.com
Vedat ÖZER
Forum Moderatörü
 
Adı Soyadı:vedat özer
Kayıt: 12 Haz 2014 15:26
Konum: ANTALYA / KEMER
Meslek: MUHASEBE
Yaş: 28
İleti: 598
 
Cinsiyet: Bay
Bulunduğunuz İl / Semt: Antalya


Forum Genel Makro Soruları

Online Kullanıcılar

Bu forumu görüntüleyenler: Sogou ve 2 misafir

Bumerang - Yazarkafe