[Yardım]  VBA ile çift koşullu düşeyara nasıl yapılır?

VBA Makrolar ile ilgili sormak istedikleriniz, yapmak istedikleriniz hakkında yardım alabileceğiniz bölümdür.

VBA ile çift koşullu düşeyara nasıl yapılır?

İleti#1)  acakilli » 11 Tem 2019 15:41

Merhaba arkadaşlar;

Başlıktanda anlaşılacağı gibi vba ile düşeyara yapmak istiyorum. Ancak bu çift koşullu olunca bir de vba olunca tıkandım.

Yapmak istediğim tam olarak exceldeki ekip sayfasında tarih ve vardiya bilgisini giriyorum. Bu verilere bağlı olarak data sayfasında eşleşen tarih ve vardiya bilgisine göre yan tarafından ekip bilgisini ekip sayfasında ilgili satıra getirecek.
Bu iletideki ekleri görmek için gerekli yetkilere sahip değilsiniz.
Kullanıcı avatarı
acakilli
Siteye Alışmış
 
Kayıt: 23 Ekm 2014 10:34
Meslek: Memur
Yaş: 26
İleti: 190
 
Cinsiyet: Bay
Bulunduğunuz İl / Semt: İstanbul / Bahçelievler

Cevap: VBA ile çift koşullu düşeyara nasıl yapılır?

İleti#2)  acakilli » 12 Tem 2019 14:59

Konuyla ilgili bilgisi olan yokmu hala uğraşıyorum. [uzgun]
Kullanıcı avatarı
acakilli
Siteye Alışmış
 
Kayıt: 23 Ekm 2014 10:34
Meslek: Memur
Yaş: 26
İleti: 190
 
Cinsiyet: Bay
Bulunduğunuz İl / Semt: İstanbul / Bahçelievler

Cevap: VBA ile çift koşullu düşeyara nasıl yapılır?

İleti#3)  svorm » 12 Tem 2019 22:56

alttaki formülü kullanabilirsin


Kod: Tümünü seç
=İNDİS(DATA!$E$3:$E$31379;KAÇINCI(Sheet1!B5;DATA!$C$3:$C$31379;0);KAÇINCI(Sheet1!F5;DATA!$D$3:$D$31379;0))
Kullanıcı avatarı
svorm
Yeni Başlamış
 
Adı Soyadı:ilker ayverdi
Kayıt: 31 Mar 2009 17:03
Konum: istanbul
Meslek: tekstil mühendisi
Yaş: 38
İleti: 27
 
Cinsiyet: Bay
Bulunduğunuz İl / Semt: İstanbul

Cevap: Cevap: VBA ile çift koşullu düşeyara nasıl yapılır?

İleti#4)  acakilli » 16 Tem 2019 10:04

svorm yazdı:alttaki formülü kullanabilirsin


Kod: Tümünü seç
=İNDİS(DATA!$E$3:$E$31379;KAÇINCI(Sheet1!B5;DATA!$C$3:$C$31379;0);KAÇINCI(Sheet1!F5;DATA!$D$3:$D$31379;0))



Merhaba;

Bunu vba ile yapmam gerekiyor.
Kullanıcı avatarı
acakilli
Siteye Alışmış
 
Kayıt: 23 Ekm 2014 10:34
Meslek: Memur
Yaş: 26
İleti: 190
 
Cinsiyet: Bay
Bulunduğunuz İl / Semt: İstanbul / Bahçelievler

REKLAM
Excel Logo XML Oluşturucu
Logo Object Designer ile Uyarlama

Cevap: VBA ile çift koşullu düşeyara nasıl yapılır?

İleti#5)  Mesut Topal » 16 Tem 2019 14:32

Kod: Tümünü seç
Set Data = Sheets("DATA")
Set s = Sheets("Sheet1")
A = WorksheetFunction.Index(Data.Cells(3, 5).Resize(31379), WorksheetFunction.Match(s.Cells(5, 2), Data.Cells(3, 3).Resize(31379), 0), WorksheetFunction.Match(s.Cells(5, 6), Data.Cells(3, 4).Resize(31379), 0))


bir dener misiniz?
Kullanıcı avatarı
Mesut Topal
Siteye Alışmış
 
Kayıt: 15 Eyl 2016 19:19
Meslek: Matematik Öğretmeni
Yaş: 32
İleti: 433
 
Cinsiyet: Bay
Bulunduğunuz İl / Semt: Samsun/Ladik


Forum Genel Makro Soruları

Online Kullanıcılar

Bu forumu görüntüleyenler: ertugrul1956, Sogou ve 1 misafir

Bumerang - Yazarkafe