FORMÜLÜ MAKRO İLE KOLAY YAPMA

VBA Makrolar ile ilgili sormak istedikleriniz, yapmak istedikleriniz hakkında yardım alabileceğiniz bölümdür.

FORMÜLÜ MAKRO İLE KOLAY YAPMA

İleti#1)  attrd112 » 21 Kas 2019 15:51

İyi günler şimdiden çok teşekkür ederim aşağıya yazacağım formülü makro ile nasıl kolay yaparım.



formülü kopyalayıp hücrelere yapıştırıyorum fakat hücrede formüle ek yapamıyorum sınır doluyor.



A1 HÜCRESİNİ D1 ye

A2 HÜCRESİNİ D2, e

A3 HÜCRESİNİ D3 ye ....



B1 HÜCRESİNİ E1 ye,

B2 HÜCRESİNİ E2 ye

B3 HÜCRESİNİ E3 ye...

diye devam edecek

kontrol edeceği hücreleri ve yazacağı hücreleri ben belirliyebilmeliyim







DİYE hücreleri benim belirliyeceğim

ve değişecek isimleri de ben belirleyeceğim





=EĞER(ESAYIYSA(BUL("SÜLEYMAN FİDAN 24";A1));"SÜLEYMAN FİDAN";EĞER(ESAYIYSA(BUL("MURAT HOPALI 24";A1));"MURAT HOPALI";EĞER(ESAYIYSA(BUL("FUAT BALKILIÇ 24";A1));"FUAT BALKILIÇ";EĞER(ESAYIYSA(BUL("CÜNEYD ÖZKÖSE 24";A1));"CÜNEYD ÖZKÖSE";EĞER(ESAYIYSA(BUL("RAMAZAN ARDA 24";A1));"RAMAZAN ARDA";EĞER(ESAYIYSA(BUL("HÜSEYİN ASLAN 24";A1));"HÜSEYİN ASLAN";" "))))))







=EĞER(ESAYIYSA(BUL("SÜLEYMAN FİDAN 24";A2));"SÜLEYMAN FİDAN";EĞER(ESAYIYSA(BUL("MURAT HOPALI 24";A2));"MURAT HOPALI";EĞER(ESAYIYSA(BUL("FUAT BALKILIÇ 24";A2));"FUAT BALKILIÇ";EĞER(ESAYIYSA(BUL("CÜNEYD ÖZKÖSE 24";A2));"CÜNEYD ÖZKÖSE";EĞER(ESAYIYSA(BUL("RAMAZAN ARDA 24";A2));"RAMAZAN ARDA";EĞER(ESAYIYSA(BUL("HÜSEYİN ASLAN 24";A2));"HÜSEYİN ASLAN";" "))))))



=EĞER(ESAYIYSA(BUL("SÜLEYMAN FİDAN 24";A2));"SÜLEYMAN FİDAN";EĞER(ESAYIYSA(BUL("MURAT HOPALI 24";A2));"MURAT HOPALI";EĞER(ESAYIYSA(BUL("FUAT BALKILIÇ 24";A2));"FUAT BALKILIÇ";EĞER(ESAYIYSA(BUL("CÜNEYD ÖZKÖSE 24";A2));"CÜNEYD ÖZKÖSE";EĞER(ESAYIYSA(BUL("RAMAZAN ARDA 24";A2));"RAMAZAN ARDA";EĞER(ESAYIYSA(BUL("HÜSEYİN ASLAN 24";A2));"HÜSEYİN ASLAN";" "))))))







=EĞER(ESAYIYSA(BUL("SÜLEYMAN FİDAN 24";B2));"SÜLEYMAN FİDAN";EĞER(ESAYIYSA(BUL("MURAT HOPALI 24";B2));"MURAT HOPALI";EĞER(ESAYIYSA(BUL("FUAT BALKILIÇ 24";B2));"FUAT BALKILIÇ";EĞER(ESAYIYSA(BUL("CÜNEYD ÖZKÖSE 24";B2));"CÜNEYD ÖZKÖSE";EĞER(ESAYIYSA(BUL("RAMAZAN ARDA 24";B2));"RAMAZAN ARDA";EĞER(ESAYIYSA(BUL("HÜSEYİN ASLAN 24";B2));"HÜSEYİN ASLAN";" "))))))
Kullanıcı avatarı
attrd112
 
Kayıt: 14 Kas 2019 19:16
Meslek: sağlık memuru
Yaş: 37
İleti: 5
 
Cinsiyet: Bay
Bulunduğunuz İl / Semt: BİLECİK

Cevap: FORMÜLÜ MAKRO İLE KOLAY YAPMA

İleti#2)  Ali ÖZ » 30 Kas 2019 10:43

Merhaba,
Bu şekilde çözüm sunmamız zor,konuyu anlamak gerekir.Örnek dosya ekleyerek yapılmasını istediğiniz işlemleri açıklarsanız yardım etmek isteyenler için de kolaylık sağlamış olursunuz.


Son güncel tutan attrd112, 30 Kas 2019 10:43.
Allah bize yeter, O ne güzel vekildir.
حَسْبُنَا اللهُ وَنِعْمَ الْوَكِيلُ
Kullanıcı avatarı
Ali ÖZ
Forum Moderatörü
 
Adı Soyadı:Ali ÖZ
Kayıt: 17 Oca 2013 10:16
Konum: SAKARYA
Meslek: Yazılım
Yaş: 38
İleti: 9956
 
Cinsiyet: Bay
Bulunduğunuz İl / Semt: Adapazarı/SAKARYA


Forum Genel Makro Soruları

Online Kullanıcılar

Bu forumu görüntüleyenler: Kayıtlı kullanıcı yok ve 1 misafir

Bumerang - Yazarkafe