1 sayfadan 1. sayfa

Birden fazla kritere göre sayfalar arası veri almak

İletiTarih: 10 Şub 2020 23:21
nasrullah
Merhabalar ekteki dosyamda Fiyatlar adlı sekmeden Ödeme Tablosu adlı sayfaya fiyatları çekmek istiyorum ancak Çekmek istediğim fiyatlar birden fazla kritere sahip olduğu için Düşeyara ile bu problemi çözemiyorum. Düzenlenme tarihi çekmek istediğim fiyatın olduğu tarih olacak bunun akabinde Öğrenim Türü ve Ödeme Yöntemi adlı kısımlarda seçim yaptıktan sonra tüm bunların kesiştiği fiyatı Liste Fiyatı kısmına getirmek istiyorum. Bu konuda yardımcı olabilirseniz sevinirim.

Cevap: Birden fazla kritere göre sayfalar arası veri almak

İletiTarih: 11 Şub 2020 13:27
Miraç CAN
=DÜŞEYARA($F$2;EĞER($I$2="Tam Gün";Fiyatlarımız!A:D;Fiyatlarımız!E:H);EĞER($I$4="Peşin";2;3);YANLIŞ)

Cevap: Birden fazla kritere göre sayfalar arası veri almak

İletiTarih: 11 Şub 2020 13:52
Ömer BARAN
Merhaba.

Sayın Miraç CAN, ayın 1'i olacak şekilde tarih girildiğinde verdiğiniz formül,
doğal olarak ilgili ayın başlık satırındaki bilgileri getiriyor.

Bu sorunu da halletmek üzere; F11 hücresi (Kayıt Ücreti) için alternatif olarak aşağıdaki formül kulanılabilir.

.
Kod: Tümünü seç
=KAYDIR(Fiyatlarımız!$A$1;KAÇINCI($F$2;Fiyatlarımız!$A:$A;0)-1+(GÜN($F$2)=1);($I$2="Tam Gün")+($I$2="Yarım Gün")*5+($I$4="Taksit"))

Cevap: Birden fazla kritere göre sayfalar arası veri almak

İletiTarih: 11 Şub 2020 14:31
nasrullah
Miraç bey ve Ömer bey ikinize de uğraş verdiğiniz ve vakit ayırdığınız için teşekkür ederim. Ömer Bey'in vermiş olduğu formül ile sıkıntımı giderdim.

Cevap: Birden fazla kritere göre sayfalar arası veri almak

İletiTarih: 11 Şub 2020 14:42
Miraç CAN
Haklısınız Ömer Bey, teşekkürler. --)(
Format içeriklerine dikkat etmemişim, hatta tarihlerin bile sıralı olduğunu şimdi fark ettim [komik]
Başlangıç seviyesi kullanıcılar için daha anlaşılır olması için düşey ara kullanmıştım.
Kaydır veya indis fonksiyonu daha kararlı.