[Yardım]  Karşılaştırma

VBA Makrolar ile ilgili sormak istedikleriniz, yapmak istedikleriniz hakkında yardım alabileceğiniz bölümdür.

Karşılaştırma

İleti#1)  emiroglu07 » 22 May 2020 09:42

Üstadlar merhaba elimde bir excel dosyası var onun beyan sayfasındaki liste ile liste sayfasındaki listenin beyanlarının verilmiş olup olmadığını nasıl göstere bilirim.
Bu iletideki ekleri görmek için gerekli yetkilere sahip değilsiniz.
Kullanıcı avatarı
emiroglu07
Site Dostu
 
Adı Soyadı:AHMET
Kayıt: 07 Oca 2014 16:36
Konum: İSTANBUL
Meslek: TEKSTİL
Yaş: 33
İleti: 551
 
Cinsiyet: Bay
Bulunduğunuz İl / Semt: DİDİM

Cevap: Karşılaştırma

İleti#2)  Justmag » 22 May 2020 21:45

düşeyara formülü ile yapabilirsiniz
Kullanıcı avatarı
Justmag
Siteye Alışmış
 
Kayıt: 16 Nis 2020 15:03
Meslek: Diğer
Yaş: 34
İleti: 108
 
Cinsiyet: Bay
Bulunduğunuz İl / Semt: Diğer

Cevap: Karşılaştırma

İleti#3)  KarıncaZ » 22 May 2020 23:22

Merhaba

Aşağıdaki iki formülü de deneye bilirsiniz.
1-)
=EĞERHATA(EĞER(EĞERSAY(BEYAN!$B$2:$B$20;D2)>=1;"Beyanname Verilmiş";"Verilmemiş");EĞER(EĞERSAY(BEYAN!$B$2:$B$20;C2)>=1;"Beyanname Verilmiş";"Verilmemiş"))

2-)
=EĞERHATA(DÜŞEYARA(D2;BEYAN!$B$2:$G$20;6;YANLIŞ);"Verilmemiş")

NOT: Artık birçok program GİB e Bağlanıp hangi beyannamelerin olup olmadığınız kontrol ederek verilmemiş beyannameleri size gösteriyor. Program danışmanınızla görüşmenizde vayda var.

Esenlikler dilerim. iyi çalışmalar.
Kullanıcı avatarı
KarıncaZ
Siteye Alışmış
 
Adı Soyadı:Zülfü YORULMAZ
Kayıt: 04 Nis 2009 21:32
Konum: KOCAELİ
Meslek: SMMM
Yaş: 41
İleti: 120
 
Cinsiyet: Bay
Bulunduğunuz İl / Semt: KOCAELİ/DERİNCE

Cevap: Karşılaştırma

İleti#4)  emiroglu07 » 27 May 2020 08:50

Zülfü bey zirve kullanıyoruz şu aralar zirve hata veriyor göndermişş olduğumuz beyanları yok sayıyor biraz sıkıntı çıkarttı o yüzden bizde 2 bir tedbir olarak bunu yapıyoruz.Yardımınız için teşlekkür ederim.
Kullanıcı avatarı
emiroglu07
Site Dostu
 
Adı Soyadı:AHMET
Kayıt: 07 Oca 2014 16:36
Konum: İSTANBUL
Meslek: TEKSTİL
Yaş: 33
İleti: 551
 
Cinsiyet: Bay
Bulunduğunuz İl / Semt: DİDİM

REKLAM
Excel Logo XML Oluşturucu
Logo Object Designer ile Uyarlama

Cevap: Karşılaştırma

İleti#5)  emiroglu07 » 29 May 2020 13:32

Zülfü bey 1 satırı doğru yapıyor diğer satırları yanlış yapıyor nedeni ne olabilir
Kullanıcı avatarı
emiroglu07
Site Dostu
 
Adı Soyadı:AHMET
Kayıt: 07 Oca 2014 16:36
Konum: İSTANBUL
Meslek: TEKSTİL
Yaş: 33
İleti: 551
 
Cinsiyet: Bay
Bulunduğunuz İl / Semt: DİDİM

Cevap: Karşılaştırma

İleti#6)  emiroglu07 » 29 May 2020 13:45

Üstada Hata burda
Bu iletideki ekleri görmek için gerekli yetkilere sahip değilsiniz.
Kullanıcı avatarı
emiroglu07
Site Dostu
 
Adı Soyadı:AHMET
Kayıt: 07 Oca 2014 16:36
Konum: İSTANBUL
Meslek: TEKSTİL
Yaş: 33
İleti: 551
 
Cinsiyet: Bay
Bulunduğunuz İl / Semt: DİDİM

REKLAM
ETA - Excel Konsolide Raporlama
ETA Excel Personel Entegre Raporu

Cevap: Karşılaştırma

İleti#7)  emiroglu07 » 01 Haz 2020 10:20

Çok Garip bir durum
Kullanıcı avatarı
emiroglu07
Site Dostu
 
Adı Soyadı:AHMET
Kayıt: 07 Oca 2014 16:36
Konum: İSTANBUL
Meslek: TEKSTİL
Yaş: 33
İleti: 551
 
Cinsiyet: Bay
Bulunduğunuz İl / Semt: DİDİM

Cevap: Karşılaştırma

İleti#8)  KarıncaZ » 02 Haz 2020 08:37

Selam Sayın Meslektaşım.

Malum biriken beyannameler nedeniyle yoğun bir dönemdi. O nedenle geç cevap yazıyorum.

Yazdığım formülün mantığı şöyle. Listedeki vergi kimlik numarasını yada tc kimlik numarasını diğer sayfada sayıyor. Eğer 1 den büyükse yani var ise beyanname gönderildi. Yok ise beyenname gönderilmedi yazıyor.

Örnek olarak gönderdiğinizde beyan sayfasında 9 haneli veri var, başı 0 olan satırlar. Bu nedenle doğruyu göstermeye bilir.

ikinci olarak beyan sayfasında TC yada Vergi numaralarının yazıldığı hücreler metin formatında, liste sayfasında sayı formatında bu nedenle farklı veri olarak algılıyordur.

Bu iki durum dışında bende çalışıyor.

Yapacağınız uygulamalarda dikkat etmeniz gereken hususlar
1-) Hücre formatlarının aynı olması. Vergi ve Tc kimlik numaraları için Metin formatını tavsiye ederim. Sayı olarak belirlenmiş hücrelerin metin formatına dönmesi için F2 -> Enter ile hücre içine girip çıkmanız gerekir.

2-) Başında 0 olan verilere dikkat etmek, =uzunluk(HücreAdresi) formülü ile hücrelerdeki karakterleri saya bilirsiniz. Bu şekilde belirleye bilirsiniz.

3-) Gib den liste çekerken bazen Tc ve Vergi numaralarının başında yada sonunda boşluk olabiliyor. bu durumu da yukardaki uzunluk formülü ile belirleye bilirsiniz.

Bu hususlara dikkat ederseniz hata almayacaksınız.

Esenlikler dilerim. İyi çalışmalar.
Kullanıcı avatarı
KarıncaZ
Siteye Alışmış
 
Adı Soyadı:Zülfü YORULMAZ
Kayıt: 04 Nis 2009 21:32
Konum: KOCAELİ
Meslek: SMMM
Yaş: 41
İleti: 120
 
Cinsiyet: Bay
Bulunduğunuz İl / Semt: KOCAELİ/DERİNCE

Cevap: Karşılaştırma

İleti#9)  KarıncaZ » 02 Haz 2020 10:14

Merhaba

Bizim Kullandığımız Beyanname takip çizelgesi ektedir. Umarım işinize yarar.

Hücrelerde Seçim yapmaya özen gösteriniz. 100 müşteri için yapılmıştır.
Bu iletideki ekleri görmek için gerekli yetkilere sahip değilsiniz.
Kullanıcı avatarı
KarıncaZ
Siteye Alışmış
 
Adı Soyadı:Zülfü YORULMAZ
Kayıt: 04 Nis 2009 21:32
Konum: KOCAELİ
Meslek: SMMM
Yaş: 41
İleti: 120
 
Cinsiyet: Bay
Bulunduğunuz İl / Semt: KOCAELİ/DERİNCE

Cevap: Karşılaştırma

İleti#10)  emiroglu07 » 02 Haz 2020 15:48

Üstadan bu yoğun dönemde zaman ayırıp soruma cevaplamanız bile çok büyük bir özveri bundan dolayı çok teşekkür ederim. şkşk
Zaman ayırıp yardımcı olmanız onure edici bir durum iyi çalışmalar dilerim.
Kullanıcı avatarı
emiroglu07
Site Dostu
 
Adı Soyadı:AHMET
Kayıt: 07 Oca 2014 16:36
Konum: İSTANBUL
Meslek: TEKSTİL
Yaş: 33
İleti: 551
 
Cinsiyet: Bay
Bulunduğunuz İl / Semt: DİDİM


Forum Genel Makro Soruları

Online Kullanıcılar

Bu forumu görüntüleyenler: OmerFaruk72, Sogou ve 3 misafir

Bumerang - Yazarkafe