Makro ile formül uygulama hakkında

VBA Makrolar ile ilgili sormak istedikleriniz, yapmak istedikleriniz hakkında yardım alabileceğiniz bölümdür.

Makro ile formül uygulama hakkında

İleti#1)  sequences » 08 Nis 2021 14:53

Merhaba arkadaşlar,

excelde makro konusunda yeni olduğum için yardıma ihtiyacım var. Ekteki örnek dosyada gösterildiği ve açıklandığı üzere butona bastığımda A sütunundaki son dolu satıra kadar B sütunundaki hücrelere formül yazdırmak istiyorum.

Yani aşağıdaki formül A2, A3,A4 şeklinde devam etmesi gerekiyor. Örnek çalışmayı incelerseniz anlayacaksınız.

Bu işi neden manuel yapmadığımı soracak olursanız da çok fazla satır olacak ve bir çok makrodan oluşan projeme ekleme yapacağım.

=DÜŞEYARA(A2;LİSTE!A:B;2;0)
Bu iletideki ekleri görmek için gerekli yetkilere sahip değilsiniz.
Kullanıcı avatarı
sequences
Yeni Başlamış
 
Kayıt: 08 Haz 2017 07:50
Meslek: operatör
Yaş: 36
İleti: 12
 
Cinsiyet: Bay
Bulunduğunuz İl / Semt: KADIKÖY

Cevap: Makro ile formül uygulama hakkında

İleti#2)  halily » 08 Nis 2021 15:19

aşağıdaki kodu dener misiniz?
Kod: Tümünü seç
Sub makro_uygula()
Dim SonStr As Long
SonStr = Cells(Rows.Count, "A").End(xlUp).Row
For x = 2 To SonStr
    Cells(x, 2).Formula = "=vlookup($A" & x & ",LİSTE!A:B,2,0)"
Next x
End Sub
Kullanıcı avatarı
halily
Siteye Alışmış
 
Kayıt: 23 May 2019 11:16
Meslek: yok
Yaş: 41
İleti: 400
 
Cinsiyet: Bay
Bulunduğunuz İl / Semt: adana


Forum Genel Makro Soruları

Online Kullanıcılar

Bu forumu görüntüleyenler: mahmut751 ve 1 misafir

Bumerang - Yazarkafe