Bir Rakamı Alt Alta Yazdırma ve Hafta Sonu Sayısı

VBA Makrolar ile ilgili sormak istedikleriniz, yapmak istedikleriniz hakkında yardım alabileceğiniz bölümdür.

Bir Rakamı Alt Alta Yazdırma ve Hafta Sonu Sayısı

İleti#1)  teyadih » 07 Mar 2018 11:25

Kolay gelsin arkadaşlar 2 formüle ihtiyacım var
1- A1 e yazdığım rakamı 1 den başlayarak B2 den itibaren aşağıya doğru yazdıracak bir formüle ihtiyacım var
Örnek A1 deki 40 rakamını 1 den başlayacak 40 da bitirecek

2- D sütununda bulunan tarihlerde kaç tane hafta sonu yani cumartesi pazar olduğunu verecek formül

Teşekkür ederim
Kullanıcı avatarı
teyadih
Siteye Alışmış
 
Kayıt: 12 Şub 2017 18:07
Meslek: Memur
Yaş: 43
İleti: 159
 
Cinsiyet: Bay
Bulunduğunuz İl / Semt: İstanbul/Yenibosna

Cevap: Bir Rakamı Alt Alta Yazdırma ve Hafta Sonu Sayısı

İleti#2)  hemso41 » 07 Mar 2018 12:08

Bunları yapacak formül bulmak çok zor. Onun yerine sayfanın change yordamına aşağıdaki kodu eklemeniz yeterli olacaktır.
Kod: Tümünü seç
Private Sub Worksheet_Change(ByVal Target As Range)

    If Target.Address = "$A$1" Then
    son = Range("d1").End(xlDown).Row
    Range("B:B").Clear
        For i = 1 To Range("a1").Value
            Cells(i, 2) = i
        Next
           
                For j = 1 To son
                    If Weekday(Cells(j, 4), vbMonday) = 6 Or Weekday(Cells(j, 4), vbMonday) = 7 Then
                        toplam = toplam + 1
                    End If
                Next
        MsgBox toplam & "adet haftasonuna denk gelen gün var"
    End If
   
   
End Sub



Kullanıcı avatarı
hemso41
Siteye Alışmış
 
Kayıt: 22 Eyl 2015 10:04
Meslek: BİLGİ İŞLEM
Yaş: 38
İleti: 335
 
Cinsiyet: Bay
Bulunduğunuz İl / Semt: izmir/karşıyaka

Cevap: Bir Rakamı Alt Alta Yazdırma ve Hafta Sonu Sayısı

İleti#3)  Ali Kırksekiz » 07 Mar 2018 12:16

A1 e yazdığım rakamı 1 den başlayarak B2 den itibaren aşağıya doğru yazdıracak bir formüle ihtiyacım var
Örnek A1 deki 40 rakamını 1 den başlayacak 40 da bitirecek


A1 sayıyı'yı yazın B1 hücresine aşağıdakini yazıp aşağı doğru çekiniz.

Kod: Tümünü seç
=EĞER(SATIRSAY($B$1:B1)>$A$1;"";SATIRSAY($B$1:B1))



D sütununda bulunan tarihlerde kaç tane hafta sonu yani cumartesi pazar olduğunu verecek formül


Kod: Tümünü seç
=TOPLA.ÇARPIM(--(HAFTANINGÜNÜ(D2:D100;2)>5)*(D2:D100<>""))


yazınız.
Ali Kırksekiz
Forum Moderatörü
 
Adı Soyadı:Ali Kırksekiz
Kayıt: 18 Eyl 2008 09:12
Konum: Sivas
Meslek: Lab ve Kalite Kontrol
Yaş: 44
İleti: 1541
 
Cinsiyet: Bay
Bulunduğunuz İl / Semt: Sivas

Cevap: Bir Rakamı Alt Alta Yazdırma ve Hafta Sonu Sayısı

İleti#4)  hemso41 » 07 Mar 2018 13:27

Ali bey çok zor demiştim geri alıyorum sözümü.Ellerinize sağlık.
Kullanıcı avatarı
hemso41
Siteye Alışmış
 
Kayıt: 22 Eyl 2015 10:04
Meslek: BİLGİ İŞLEM
Yaş: 38
İleti: 335
 
Cinsiyet: Bay
Bulunduğunuz İl / Semt: izmir/karşıyaka

REKLAM
Excel Logo XML Oluşturucu
Logo Object Designer ile Uyarlama

Cevap: Cevap: Bir Rakamı Alt Alta Yazdırma ve Hafta Sonu Say

İleti#5)  Ali Kırksekiz » 07 Mar 2018 15:04

hemso41 yazdı:Ali bey çok zor demiştim geri alıyorum sözümü.Ellerinize sağlık.


Sizinde ellerinize sağlık. --)(
Ali Kırksekiz
Forum Moderatörü
 
Adı Soyadı:Ali Kırksekiz
Kayıt: 18 Eyl 2008 09:12
Konum: Sivas
Meslek: Lab ve Kalite Kontrol
Yaş: 44
İleti: 1541
 
Cinsiyet: Bay
Bulunduğunuz İl / Semt: Sivas

Cevap: Bir Rakamı Alt Alta Yazdırma ve Hafta Sonu Sayısı

İleti#6)  Murat OSMA » 07 Mar 2018 15:37

İlk isteğe alternatif olarak bu formülü de kullanabilirsiniz..

Kod: Tümünü seç
=($A$1>=SATIR())*SATIR()

Hücre Biçimlendirmeden İsteğe Uyarlanmışı seçin, Tür kısmına da 0;; yazıp Tamam deyin..
Kullanıcı avatarı
Murat OSMA
Site Forum Yöneticisi
 
Adı Soyadı:Murat OSMA
Kayıt: 05 Arl 2008 00:34
Konum: İstanbul
Meslek: Excel & VBA Eğitmeni
Yaş: 33
İleti: 14306
 
Cinsiyet: Bay
Bulunduğunuz İl / Semt: Bağcılar - İSTANBUL

REKLAM
ETA - Excel Konsolide Raporlama
ETA Excel Personel Entegre Raporu

Cevap: Bir Rakamı Alt Alta Yazdırma ve Hafta Sonu Sayısı

İleti#7)  teyadih » 26 Haz 2018 14:49

Teşekkür ederim arkadaşlar kusura bakmayın geç dönüş yaptım.
Kullanıcı avatarı
teyadih
Siteye Alışmış
 
Kayıt: 12 Şub 2017 18:07
Meslek: Memur
Yaş: 43
İleti: 159
 
Cinsiyet: Bay
Bulunduğunuz İl / Semt: İstanbul/Yenibosna

Cevap: Bir Rakamı Alt Alta Yazdırma ve Hafta Sonu Sayısı

İleti#8)  teyadih » 11 Tem 2018 09:56

Sayın Ali Kırksekiz. Yazmış olduğunuz
=EĞER(SATIRSAY($B$1:B1)>$A$1;"";SATIRSAY($B$1:B1)) formülü 1 den başlayış 40 a kadar gidiyor bunu tam tersi 40 dan başlayış 0 a kadar düşecek şekilde,
=TOPLA.ÇARPIM(--(HAFTANINGÜNÜ(D2:D100;2)>5)*(D2:D100<>"")) formülünü ise D sütunundaki hafta sonları ile E sütununda bulunan resmi tatil tarihlerin toplamını verecek şekilde yapabilir misiniz rica etsem.
Kullanıcı avatarı
teyadih
Siteye Alışmış
 
Kayıt: 12 Şub 2017 18:07
Meslek: Memur
Yaş: 43
İleti: 159
 
Cinsiyet: Bay
Bulunduğunuz İl / Semt: İstanbul/Yenibosna

Cevap: Cevap: Bir Rakamı Alt Alta Yazdırma ve Hafta Sonu Say

İleti#9)  Ali Kırksekiz » 12 Tem 2018 10:27

teyadih yazdı:Sayın Ali Kırksekiz. Yazmış olduğunuz
=EĞER(SATIRSAY($B$1:B1)>$A$1;"";SATIRSAY($B$1:B1)) formülü 1 den başlayış 40 a kadar gidiyor bunu tam tersi 40 dan başlayış 0 a kadar düşecek şekilde,


Kod: Tümünü seç
=EĞER(SATIRSAY($B$1:B1)>$A$1;"";$A$1-SATIRSAY($B$1:B1)+1)


teyadih yazdı:=TOPLA.ÇARPIM(--(HAFTANINGÜNÜ(D2:D100;2)>5)*(D2:D100<>"")) formülünü ise D sütunundaki hafta sonları ile E sütununda bulunan resmi tatil tarihlerin toplamını verecek şekilde yapabilir misiniz rica etsem.


E sütununda sadece resmi tatiller olsun.

Kod: Tümünü seç
=TOPLA.ÇARPIM(--(HAFTANINGÜNÜ(D2:D100;2)>5)*(D2:D100<>""))+BAĞ_DEĞ_DOLU_SAY(E2:E100)
Ali Kırksekiz
Forum Moderatörü
 
Adı Soyadı:Ali Kırksekiz
Kayıt: 18 Eyl 2008 09:12
Konum: Sivas
Meslek: Lab ve Kalite Kontrol
Yaş: 44
İleti: 1541
 
Cinsiyet: Bay
Bulunduğunuz İl / Semt: Sivas

Cevap: Bir Rakamı Alt Alta Yazdırma ve Hafta Sonu Sayısı

İleti#10)  teyadih » 12 Tem 2018 15:12

Teşekkür ederim sayın ali kırksekiz elinize sağlık. Resmi tatil günlerinin eklenmesiyle ilgili eksik bilgi vermişim kusura bakmayın. Belirtilen tarihler arasındaki hafta sonları ile resmi tatil sayısını verecek bir formüle ihtiyacım var. Örnek belgeyi ekte gönderiyorum.
teşekkür ederim tekrar
Bu iletideki ekleri görmek için gerekli yetkilere sahip değilsiniz.
Kullanıcı avatarı
teyadih
Siteye Alışmış
 
Kayıt: 12 Şub 2017 18:07
Meslek: Memur
Yaş: 43
İleti: 159
 
Cinsiyet: Bay
Bulunduğunuz İl / Semt: İstanbul/Yenibosna

Cevap: Bir Rakamı Alt Alta Yazdırma ve Hafta Sonu Sayısı

İleti#11)  teyadih » 12 Tem 2018 16:40

Ali bey sizi yoruyorum hakkınızı helal edin son yaptığınız formülü =EĞERHATA(EĞER(SATIRSAY(E1:E1)>E1;"0";E1-SATIRSAY(E1:E1)-2);) bu şekilde yaparak 3 er 3 er düşmesi şeklinde ayarladım ancak ilk yaptığınız =EĞER(SATIRSAY($B$1:B1)>$A$1;"";SATIRSAY($B$1:B1)) formülünü 40 a kadar 3 er 3 er atmasını yapamadım. Size zahmet buna da bakar mısınız
Kullanıcı avatarı
teyadih
Siteye Alışmış
 
Kayıt: 12 Şub 2017 18:07
Meslek: Memur
Yaş: 43
İleti: 159
 
Cinsiyet: Bay
Bulunduğunuz İl / Semt: İstanbul/Yenibosna

Cevap: Bir Rakamı Alt Alta Yazdırma ve Hafta Sonu Sayısı

İleti#12)  Ali Kırksekiz » 13 Tem 2018 15:39

Kod: Tümünü seç
=EĞER(SATIRSAY($B$1:$B1)*3-3+1>$A$1;"";SATIRSAY($B$1:$B1)*3-3+1)
Ali Kırksekiz
Forum Moderatörü
 
Adı Soyadı:Ali Kırksekiz
Kayıt: 18 Eyl 2008 09:12
Konum: Sivas
Meslek: Lab ve Kalite Kontrol
Yaş: 44
İleti: 1541
 
Cinsiyet: Bay
Bulunduğunuz İl / Semt: Sivas

Cevap: Bir Rakamı Alt Alta Yazdırma ve Hafta Sonu Sayısı

İleti#13)  teyadih » 13 Tem 2018 19:26

Teşekkür ederim ali bey pazartesi işe gittiğimde deneyeceğim formülü
Gönderdiğim dosyayı inceleyebildiniz mi acaba
Kullanıcı avatarı
teyadih
Siteye Alışmış
 
Kayıt: 12 Şub 2017 18:07
Meslek: Memur
Yaş: 43
İleti: 159
 
Cinsiyet: Bay
Bulunduğunuz İl / Semt: İstanbul/Yenibosna

Cevap: Bir Rakamı Alt Alta Yazdırma ve Hafta Sonu Sayısı

İleti#14)  teyadih » 16 Tem 2018 09:58

Sıkıntı yok ali bey elinize sağlık.
Kullanıcı avatarı
teyadih
Siteye Alışmış
 
Kayıt: 12 Şub 2017 18:07
Meslek: Memur
Yaş: 43
İleti: 159
 
Cinsiyet: Bay
Bulunduğunuz İl / Semt: İstanbul/Yenibosna

Cevap: Bir Rakamı Alt Alta Yazdırma ve Hafta Sonu Sayısı

İleti#15)  teyadih » 14 Eyl 2018 15:48

Kolay gelsin arkadaşlar. Sayın Ali Kırksekiz'in yukarıda yaptığı formülle benzer bir formüle ihtiyacım var. Eğer AK1 30 ise alt alta 30 tane 1, 20 ise 20 tane 1 yazacak, yani AK1 de kaç yazıyorsa alt alta o kadar 1 yazacak bir formüle ihtiyacım var. Teşekkür ederim
Kullanıcı avatarı
teyadih
Siteye Alışmış
 
Kayıt: 12 Şub 2017 18:07
Meslek: Memur
Yaş: 43
İleti: 159
 
Cinsiyet: Bay
Bulunduğunuz İl / Semt: İstanbul/Yenibosna


Forum Genel Makro Soruları

Online Kullanıcılar

Bu forumu görüntüleyenler: Yandex[Bot] ve 5 misafir

cron
Bumerang - Yazarkafe