satırdaki isimleri sütundaki isimlerle eşleştirip formül yaz

Excel hakkındaki soru ya da paylaşımlarınıza kategori bulamadıysanız bu alana yazabilirsiniz.

satırdaki isimleri sütundaki isimlerle eşleştirip formül yaz

İleti#1)  matrax410 » 11 Şub 2020 15:50

merhabalar,

excel dosyamın içinde anlattım. kısaca şöyle anlayatım.

aynı sütunda 3 ayrı isim var. 3 ayrı sütunda bu isimlerin toplam hanesi var.
arada başka sütunlarda var.

3 ayrı isimleri toplama çıkarmalarını diğer 3 ayrı sütundaki ilgili yerlere formülünü oluşturacağım.

şimdiden teşekkür ederim.
Bu iletideki ekleri görmek için gerekli yetkilere sahip değilsiniz.
Kullanıcı avatarı
matrax410
Siteye Alışmış
 
Kayıt: 28 Haz 2018 23:10
Meslek: TEKteknisyen
Yaş: 46
İleti: 106
 
Cinsiyet: Bay
Bulunduğunuz İl / Semt: kocaeli

Cevap: satırdaki isimleri sütundaki isimlerle eşleştirip for

İleti#2)  tdemirhan » 11 Şub 2020 16:29

Merhaba;

Dosyada da bahsetmişsin ama maalesef algılayamadım yapmak istediğinizi tekrar anlatabilir misiniz? K1, K2, K3 toplamlarını istemiyorsunuz anladığım kadarıyla, ki öyle olsaydı "ETOPLA" formülü ile işinizi görebilirdiniz, yanılıyor muyum?
Kullanıcı avatarı
tdemirhan
Yeni Başlamış
 
Kayıt: 11 Nis 2019 15:43
Meslek: teniker
Yaş: 32
İleti: 61
 
Cinsiyet: Bay
Bulunduğunuz İl / Semt: Denizli/Merkezefendi

Cevap: satırdaki isimleri sütundaki isimlerle eşleştirip for

İleti#3)  matrax410 » 11 Şub 2020 17:56

merhaba , şöyle anlatayım.
SAHA yazan B sütununda K1,K2 K3 isimleri var.
TOPLAM (kg) yazan H;I;J sütunları

Toplam sütunlarındaki formülü öyle yapalım ki,
B sütununda K1 yazıyorsa Toplam J sütunundaki işlemleri yapsın (formülü unutmayalım)

B sütununda K2 yazıyorsa Toplam I sütunundaki işlemleri yapsın

B sütununda K3 yazıyorsa Toplam H sütunundaki işlemleri yapsın

B sütunudaki isimler hergün yazılı olmayabilir. Kısaca B sütunundaki isim K1 yazıyorsa gidip H sütunnundaki K3 'e verileri yazmasın.

aynısının karşılığında işlemleri yapsın.

teşekkür ederim.
Kullanıcı avatarı
matrax410
Siteye Alışmış
 
Kayıt: 28 Haz 2018 23:10
Meslek: TEKteknisyen
Yaş: 46
İleti: 106
 
Cinsiyet: Bay
Bulunduğunuz İl / Semt: kocaeli

Cevap: satırdaki isimleri sütundaki isimlerle eşleştirip for

İleti#4)  OmerFaruk72 » 13 Şub 2020 18:31

Gönderdiğiniz dosya için aşağıdaki formülleri sırasıyla yapıştırın
Her formülü girdikten sonra hücre içindeyken CTRL+SHIFT+ENTER tuşuna basarak DİZİ formülü olmasını sağlayın

H3 hücresine
Kod: Tümünü seç
=EĞER($B3="K3";ARA(2;1/($H$2:H2<>"");$H$2:H2)+$C3-$D3-$E3-$F3-$G3;"")

I3 hücresine
Kod: Tümünü seç
=EĞER($B3="K2";ARA(2;1/($I$2:I2<>"");$I$2:I2)+$C3-$D3-$E3-$F3-$G3;"")

J3 hücresine
Kod: Tümünü seç
=EĞER($B3="K1";ARA(2;1/($J$2:J2<>"");$J$2:J2)+$C3-$D3-$E3-$F3-$G3;"")


Dizi formülü haline gelince aşağıdaki görüntü olmalı. Örnek H3 için
Kod: Tümünü seç
{=EĞER($B3="K1";ARA(2;1/($J$2:J2<>"");$J$2:J2)+$C3-$D3-$E3-$F3-$G3;""}
Kullanıcı avatarı
OmerFaruk72
Yeni Başlamış
 
Kayıt: 15 Ekm 2018 10:39
Meslek: Elektrik Mühendisi
Yaş: 47
İleti: 88
 
Cinsiyet: Bay
Bulunduğunuz İl / Semt: Ankara/Çankaya

REKLAM
Excel Logo XML Oluşturucu
Logo Object Designer ile Uyarlama

Cevap: satırdaki isimleri sütundaki isimlerle eşleştirip for

İleti#5)  OmerFaruk72 » 13 Şub 2020 18:32

H3-I3-J3 satırlarında Dizi formülü oluşturduktan sonra formülleri aşağıya doğru sürükleyerek yapıştırabilirsiniz
Kullanıcı avatarı
OmerFaruk72
Yeni Başlamış
 
Kayıt: 15 Ekm 2018 10:39
Meslek: Elektrik Mühendisi
Yaş: 47
İleti: 88
 
Cinsiyet: Bay
Bulunduğunuz İl / Semt: Ankara/Çankaya

Cevap: satırdaki isimleri sütundaki isimlerle eşleştirip for

İleti#6)  matrax410 » 15 Şub 2020 14:46

merhaba Ömer Faruk hocam ,

öncelikle eline sağlık.

formülü uyguladım. doğru çalışıyor. sadece toplam sonuçları bir alt sıraya yazıyor.

3 satıra girdiğim verinin toplamı H4 ; I4;J4 satırına yazıyor. tam karşısına yazmıyor.

geri kaln mükemmel.
Kullanıcı avatarı
matrax410
Siteye Alışmış
 
Kayıt: 28 Haz 2018 23:10
Meslek: TEKteknisyen
Yaş: 46
İleti: 106
 
Cinsiyet: Bay
Bulunduğunuz İl / Semt: kocaeli

REKLAM
ETA - Excel Konsolide Raporlama
ETA Excel Personel Entegre Raporu

Cevap: satırdaki isimleri sütundaki isimlerle eşleştirip for

İleti#7)  Ömer BARAN » 18 Şub 2020 02:22

Merhaba.

Ben de tek formül olacak şekilde alternatif bir cevap vereyim dedim.
Formül dizi formülü olup H3 hücresine CTRL+SHIFT+ENTER tuşuyla tamamlanmalıdır.

Formülü, dizi formülü olarak H3 hücresine uyuladıktan sonra sağa ve aşağı kopyalayın.

.
Kod: Tümünü seç
=EĞER($B3="";"";EĞER(--SAĞDAN($B3;1)=SÜTUNSAY(H$1:$J$1);(KAYDIR(H$1;BÜYÜK(EĞER(H$2:H2<>"";SATIR(H$2:H2));1)-1;)+$C3-TOPLA($D3:$G3));""))
☾✭ İnadına TÜRKÇE ✭☽

Sorularınızı bana https://www.ExcelDestek.Com 'dan da sorabilirsiniz.




.
Kullanıcı avatarı
Ömer BARAN
Siteye Alışmış
 
Adı Soyadı:ÖMER BARAN
Kayıt: 29 Oca 2013 16:17
Konum: ANKARA
Meslek: EMEKLİ
Yaş: 56
İleti: 225
 
Cinsiyet: Bay
Bulunduğunuz İl / Semt: ANKARA / ÇANKAYA

Cevap: satırdaki isimleri sütundaki isimlerle eşleştirip for

İleti#8)  matrax410 » 18 Şub 2020 10:16

merhaba Ömer hocam,

süper olmuş. elinize yüreğinize sağlık....

çok teşekkür ederim.

sağlıcakla kalın...
Kullanıcı avatarı
matrax410
Siteye Alışmış
 
Kayıt: 28 Haz 2018 23:10
Meslek: TEKteknisyen
Yaş: 46
İleti: 106
 
Cinsiyet: Bay
Bulunduğunuz İl / Semt: kocaeli

Cevap: Cevap: satırdaki isimleri sütundaki isimlerle eşleşti

İleti#9)  Ömer BARAN » 18 Şub 2020 12:11

matrax410 yazdı:merhaba Ömer hocam,
süper olmuş. elinize yüreğinize sağlık....
çok teşekkür ederim.
sağlıcakla kalın...

--)(
Cevaplarımın altındaki İMZA bölümünde yer alan forum sitesine de beklerim.
Formülün kısalması bakımından; SÜTUNSAY(H$1:$J$1) yerine, 11-SÜTUN() de yazılabilir.

İyi çalışmalar dilerim.

.
☾✭ İnadına TÜRKÇE ✭☽

Sorularınızı bana https://www.ExcelDestek.Com 'dan da sorabilirsiniz.




.
Kullanıcı avatarı
Ömer BARAN
Siteye Alışmış
 
Adı Soyadı:ÖMER BARAN
Kayıt: 29 Oca 2013 16:17
Konum: ANKARA
Meslek: EMEKLİ
Yaş: 56
İleti: 225
 
Cinsiyet: Bay
Bulunduğunuz İl / Semt: ANKARA / ÇANKAYA


Forum Diğer Excel İşlemleri

Online Kullanıcılar

Bu forumu görüntüleyenler: Kayıtlı kullanıcı yok ve 0 misafir

Bumerang - Yazarkafe