eğer fonksiyonu filitreleme yardım...

VBA Makrolar ile ilgili sormak istedikleriniz, yapmak istedikleriniz hakkında yardım alabileceğiniz bölümdür.

eğer fonksiyonu filitreleme yardım...

İleti#1)  psocheck » 12 Haz 2018 12:26

arkadaşlar bir analiz yapmam lazım
=EĞERSAY fonksiyonu ile aynı isimden kaç kişi var farklı bir sütuna yazdırmak istiyorum.

örnek verecek olursak.

D sütünün da ali can 7 kere yazıyor. bunu diğer sütüna 7 diye aktarmam lazım.
=EĞERSAY fonksiyonu ile bunu yapabilirmiyim.
Beceremedim yardım edin lütfen.
Kullanıcı avatarı
psocheck
Yeni Başlamış
 
Kayıt: 07 May 2018 11:38
Meslek: YAZILIM
Yaş: 33
İleti: 21
 
Cinsiyet: Bay
Bulunduğunuz İl / Semt: ankara

Cevap: eğer fonksiyonu filitreleme yardım...

İleti#2)  MDAGISTANLI » 12 Haz 2018 12:42

EĞERSAY veya Pivot;

psocheck_isim say.zip
Bu iletideki ekleri görmek için gerekli yetkilere sahip değilsiniz.
Kullanıcı avatarı
MDAGISTANLI
Yeni Başlamış
 
Kayıt: 28 Arl 2017 18:57
Meslek: Microsoft Sistem Yöneticisi
Yaş: 39
İleti: 46
 
Cinsiyet: Bay
Bulunduğunuz İl / Semt: İstanbul / Başakşehir

Cevap: eğer fonksiyonu filitreleme yardım...

İleti#3)  psocheck » 12 Haz 2018 12:59

hocam kodu buraya yazarmısınız;(pivot). excel yeniyim.
Kullanıcı avatarı
psocheck
Yeni Başlamış
 
Kayıt: 07 May 2018 11:38
Meslek: YAZILIM
Yaş: 33
İleti: 21
 
Cinsiyet: Bay
Bulunduğunuz İl / Semt: ankara

Cevap: eğer fonksiyonu filitreleme yardım...

İleti#4)  psocheck » 12 Haz 2018 13:04

hocam olmadı 0 yazıyor.
Kullanıcı avatarı
psocheck
Yeni Başlamış
 
Kayıt: 07 May 2018 11:38
Meslek: YAZILIM
Yaş: 33
İleti: 21
 
Cinsiyet: Bay
Bulunduğunuz İl / Semt: ankara

REKLAM
Excel Logo XML Oluşturucu
Logo Object Designer ile Uyarlama

Cevap: eğer fonksiyonu filitreleme yardım...

İleti#5)  MDAGISTANLI » 12 Haz 2018 13:26

Kod: Tümünü seç
=EĞERSAY($A$2:$A$7;A2)


Formülde İSİM alanının sabit kalması yani dinamik olmaması için sütun ve satır başlarında $ olmalı: $A$2:$A$7 (A2:A7'yi seçip F4'e basıldığında kilit seçenekleri arasında geçiş yapar)

screenshot.2018-06-12.jpg


Formülü kendi dosyanıza uyarlayabilecek misiniz?

Alternatif olarak pivot kullanmak isterseniz;
Tablonuzu seçin, Ekle\Pivot Table | Tamam
İSİM alanını SATIRLAR ve DEĞERLER bölgelerine sürükleyin.

screenshot.2018-06-12 (1).jpg


Pivotu kavramak için zengin içerikli bir dosyada denemeler yapın;
Değerleri Özetleme Ölçütü'nde genelde SAY veya TOPLAM tercihleri kullanılır.
Bu iletideki ekleri görmek için gerekli yetkilere sahip değilsiniz.
Kullanıcı avatarı
MDAGISTANLI
Yeni Başlamış
 
Kayıt: 28 Arl 2017 18:57
Meslek: Microsoft Sistem Yöneticisi
Yaş: 39
İleti: 46
 
Cinsiyet: Bay
Bulunduğunuz İl / Semt: İstanbul / Başakşehir

Cevap: eğer fonksiyonu filitreleme yardım...

İleti#6)  psocheck » 12 Haz 2018 13:37

çok teşekkür ederim işime yaradı.
Kullanıcı avatarı
psocheck
Yeni Başlamış
 
Kayıt: 07 May 2018 11:38
Meslek: YAZILIM
Yaş: 33
İleti: 21
 
Cinsiyet: Bay
Bulunduğunuz İl / Semt: ankara

REKLAM
ETA - Excel Konsolide Raporlama
ETA Excel Personel Entegre Raporu

Forum Genel Makro Soruları

Online Kullanıcılar

Bu forumu görüntüleyenler: Google [Bot] ve 2 misafir

Bumerang - Yazarkafe