Tarih den ay ve yıl esasından; tablodaki verideki karşılığı tespit

Cevapla
erseldemirel
Mesajlar: 100
Kayıt: Cmt Haz 24, 2023 12:23 am
Web Sitesi: https://erseldemirel.com.tr/
Adınız: Ersel
Soyadınız: Demirel

Tarih den ay ve yıl esasından; tablodaki verideki karşılığı tespit

Mesaj gönderen erseldemirel »

Arkadaşlar ekteki excelde üfe adlı sekme var. birde data adlı sekme var. data adlı sekmede tarihler var. buradaki tarihlerden ay ve yıla göre üfe tablosundaki verinin tespit edilmesi lazım. bu formül ve makro kodu ile ayrı ayrı çözülürse çok işime yarayacak. teşekkür ederim


https://s2.dosya.tc/server25/4763tw/TEST.xlsm.html
En son Tarkan VURAL tarafından Pzt Eyl 04, 2023 4:56 pm tarihinde düzenlendi, toplamda 1 kere düzenlendi.
Sebep: Dosya eki ilave edilmiştir.
uygaroz
Mesajlar: 1
Kayıt: Çrş Tem 05, 2023 11:20 am
Lokasyon: Denizli
Meslek: Pazarlama Sorumlusu
Adınız: Uygar
Soyadınız: Öz.

Re: Tarih den ay ve yıl esasından; tablodaki verideki karşılığı tespit

Mesaj gönderen uygaroz »

Şu formülü deneyebilir misiniz.
C2 hücresi

Kod: Tümünü seç

=DÜŞEYARA(YIL($B2);ÜFE!$A$1:$M$32;AY($B2)+1;0)
erseldemirel
Mesajlar: 100
Kayıt: Cmt Haz 24, 2023 12:23 am
Web Sitesi: https://erseldemirel.com.tr/
Adınız: Ersel
Soyadınız: Demirel

Re: Tarih den ay ve yıl esasından; tablodaki verideki karşılığı tespit

Mesaj gönderen erseldemirel »

Makro ile yaptım; yaptıgınız formülde güzel oldu teşekkürler
Kullanıcı avatarı
Tarkan VURAL
Doğrulandı
Site Admin
Mesajlar: 59
Kayıt: Prş Haz 22, 2023 12:03 am
Lokasyon: İstanbul
Web Sitesi: http://www.tarkanvural.com.tr
Meslek: Yazılım ve Veri Tabanı Uzmanı
Adınız: Tarkan
Soyadınız: VURAL
İletişim:

Re: Tarih den ay ve yıl esasından; tablodaki verideki karşılığı tespit

Mesaj gönderen Tarkan VURAL »

Merhaba,
Uygar bey zaten çözümü sunmuş. Ben de sevdiğim TOPLA.ÇARPIM formülü ile bir örnek geliştirdim. Aynı zamanda hem makro hem de KTF ile ilgili farklı mantıklarda çözümler düzenledim.

Dosya ekinden kontrol edebilirsiniz.

Kod: Tümünü seç

Sub YillaraGoreUfeSonuc()
With Sheets("DATA")
For Each Kayit In .Range("b2:b" & .Range("b65536").End(3).Row)
    ay = Month(Kayit) + 1
    Set Hedef = Sheets("ÜFE").Range("a:A").Find(Year(Kayit), , , 1)
    If Not Hedef Is Nothing Then
        Kayit.Offset(0, 3).Value = Sheets("ÜFE").Cells(Hedef.Row, ay)
    End If
Next
End With
End Sub

Kod: Tümünü seç

Function UFE(ByVal Hedef As Range)
With Sheets("ÜFE")
yil = .Range("a:a").Find(Year(Hedef.Value), , , 1).Row
ay = .Range("b1:m1").Find(UCase(MonthName(Month(Hedef.Value))), , , 1).Column
UFE = .Cells(yil, ay).Value
End With
End Function
Bu mesaja eklenen dosyaları görüntülemek için gerekli izinlere sahip değilsiniz.
Konu Dışı
Logo Yazılım, Özel Yazılım, Entegrasyon işlemleri, Excel VBA kodlama, Raporlama, Eğitim.. gibi konulardaki destek ihtiyaçlarınız içinhelpdesk@evnyazilim.com.trile irtibata geçebilirsiniz.
Cevapla
  • Benzer Konular
    Cevaplar
    Görüntüleme
    Son mesaj